Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Problemas con SSL e Inicio de sesionTema Solucionado

Foros de soporte phpBB 3.3


RuMag85
Observador/a
Mensajes: 2
Registrado: 10 Jun 2020, 09:53
Género:

Problemas con SSL e Inicio de sesion

#1

Mensaje por RuMag85 »

URL: www.forofrikis.es
Estilos prosilver,metrolike red
Extensiones instaladas: analitycts,seo metadata,Advertisement Management,Breadcrumb Menu,phpBB mentions,s9e/mediaembed,Privacy policy,VigLink
Versión de phpBB:3.3.0
Versión de PHP: 7.3.17
Versión de MySQL: 5.6.47
Servidor: pago

Buenas a todos
Soy nuevo por estos foros, y os encontre buscando informacion por internet.
Tengo un foro en un hosting de pago,con el SSL activado y no consigo configurarlo en mi foro,he seguido varios tutoriales que he encontrado tanto por google como por aqui,pero no consigo hacerlo funcionar,dandome error(SSL_ERROR_RX_RECORD_TOO_LONG) y si lo consigo me da error en las cookies y se me deslogua el usuario o los usuarios.
Ya no se que mas hacer.

Saludos y gracias





Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1052
Registrado: 14 Ene 2017, 22:18
Género:

Problemas con SSL e Inicio de sesion

#2

Mensaje por AbaddonOrmuz »

Bienvenido @RuMag85,

No estoy muy seguro de el error SSL_ERROR_RX_RECORD_TOO_LONG porque ese lo he visto con sitios que usan algoritmos ahora considerados inseguros en sus certificados.

Con respecto a las cookies, intenta corregirlas ya que en tu caso el dominio de la cookie debería ser .forofrikis.es nótese el punto inicial.

Más información: Corregir una incorrecta configuración de las cookies

Si no puedes hacerlo desde el PCA porque te cierra sesión antes de terminar, puedes hacerlo ejecutando la siguiente consulta SQL desde phpMyAdmin.

Código: Seleccionar todo

UPDATE phpbb_config SET config_value = '.forofrikis.es' WHERE config_name = 'cookie_domain';

Remplaza phpbb_ si ese no es el prefijo de tus tablas.

Más información: Ejecutar consultas SQL en phpMyAdmin

Luego de ello es muy importante que elimines la caché desde el PCA o manualmente, para éste último hay que eliminar (por FTP o SSH) el contenido de la carpeta cache/production/ que se encuentra dentro de la raíz de tu foro.

También elimina las cookies de tu navegador para evitar algún conflicto.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
RuMag85
Observador/a
Mensajes: 2
Registrado: 10 Jun 2020, 09:53
Género:

Problemas con SSL e Inicio de sesion

#3

Mensaje por RuMag85 »

Buenas,tengo la configuracion tal como muestro en las imagenes adjuntas,pero me sigue fallando, y el error es este : Código de error: SSL_ERROR_RX_RECORD_TOO_LONG

Código: Seleccionar todo

https://www.forofrikis.es:80/index.php?sid=760bfc54c1a01bbc4fa741c8b3809a5d
SSL_ERROR_RX_RECORD_TOO_LONG

Saludos

Adjuntos
2.png
1.png


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1052
Registrado: 14 Ene 2017, 22:18
Género:

Problemas con SSL e Inicio de sesion

#4

Mensaje por AbaddonOrmuz »

Puedes intentar desactivando la opción "Forzar parámetro URL", la ruta de phpBB (que parece estar vacía) y corrigiendo el puerto del servidor.

Cuando un sitio esta configurado para HTTPS, se usa el puerto 443 y justo ahora estas forzando el uso del puerto 80 (HTTP) para HTTPS.

Código: Seleccionar todo

UPDATE phpbb_config SET config_value = '0' WHERE config_name = 'force_server_vars';
UPDATE phpbb_config SET config_value = '443' WHERE config_name = 'server_port';
UPDATE phpbb_config SET config_value = '/' WHERE config_name = 'cookie_path';

Igualmente hay que eliminar la caché y cookies del navegador.

Más información: Configurar conexión segura (HTTPS) con un certificado SSL

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1052
Registrado: 14 Ene 2017, 22:18
Género:

Problemas con SSL e Inicio de sesion  Tema Solucionado

#5

Mensaje por AbaddonOrmuz »

Veo que has cambiado de sistema de foros, así que marco como solucionado este tema.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.3”