Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Error Fatal, no encuentra template....Tema Solucionado

🔎 Foros de soporte phpBB 3.2
Cerrado
JAR_AMD
Observador/a
Mensajes: 4
Registrado: 05 Ago 2019, 09:31
Nombre real: Jose
Género:

Error Fatal, no encuentra template....  Tema Solucionado

Mensaje por JAR_AMD » 05 Ago 2019, 09:42


Datos de Soporte - Inicio

URL: www.clio16v-williams.es/foro
Estilo(s) usuado(s): we_universal 2.5.8
MODs/Extensiones instaladas:
- Posting Template
- Topic Prefixes
- Media Embedded
- Advanced BB Code
- Sortables Captcha
Versión de phpBB:3.2.7
Versión de PHP en tu servidor:7.2.X
Tipo de base de datos y versión en tu servidor:MySQL(i) 5.5

Tu conocimiento: Conocimiento básico, aficionado.
Servidor: 1&1 IONOS
Es una actualización desde otra versión: Actualizado desde la versión 3.0.9

Bueno, a ver si consigo poner mi problema.

El caso es que hace dos días actualizamos el foro desde la versión 3.0.9 a la 3.2.7, usando un tutorial de @canidev y todo fue sin problemas, hicimos pruebas revisamos todo y funcionó perfecto.
Acto seguido instalamos el Estilo we_universal, todo bien, lo configuramos y perfecto. Se fueron instalando Extensiones, las indicadas y todo bien, de hecho el foro ha estado funcionando, ha habido registros nuevos, y por fin pudimos capar el Spam.

El caso es que hoy procedo a entrar a revisar unas cosas y me sale este error:

Código: Seleccionar todo

Fatal error: Uncaught Twig\Error\LoaderError: Unable to find template "@derky_sortablescaptcha/event/overall_header_head_append.html" (looked into: ) in "overall_header.html" at line 73. in /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Loader/FilesystemLoader.php:245 Stack trace: #0 /homepages/26/d393251611/htdocs/foro/phpbb/template/twig/loader.php(135): Twig\Loader\FilesystemLoader->findTemplate('@derky_sortable...') #1 /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Loader/FilesystemLoader.php(155): phpbb\template\twig\loader->findTemplate('@derky_sortable...') #2 /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Environment.php(351): Twig\Loader\FilesystemLoader->getCacheKey('@derky_sortable...') #3 /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Environment.php(445): Twig\Environment->getTemplateClass('@derky_sortable...') #4 /homepages/26/d393251611/htdocs/foro/phpbb/template/twig/environment.php(292): Twig\Environment->loadTemplate('@derky_sortable...', NULL) #5 /homepages/26 in /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Loader/FilesystemLoader.php on line 245
Previamente salio otro similar pero no encontraba index_body.html.

Todo viene provocado del estilo, pero no se como solucionarlo ya que no puedo acceder al ACP.

Espero podáis echarme una mano.

Un saludo y muchas gracias.




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

JAR_AMD
Observador/a
Mensajes: 4
Registrado: 05 Ago 2019, 09:31
Nombre real: Jose
Género:

Error Fatal, no encuentra template....

Mensaje por JAR_AMD » 05 Ago 2019, 10:41

Otro error:

Código: Seleccionar todo

Fatal error: Uncaught Twig\Error\LoaderError: Unable to find template "index_body.html" (looked into: /homepages/26/d393251611/htdocs/foro/styles/we_universal/template, /homepages/26/d393251611/htdocs/foro/styles/we_universal/theme, /homepages/26/d393251611/htdocs/foro/styles/all/template). in /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Loader/FilesystemLoader.php:245 Stack trace: #0 /homepages/26/d393251611/htdocs/foro/phpbb/template/twig/loader.php(135): Twig\Loader\FilesystemLoader->findTemplate('index_body.html') #1 /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Loader/FilesystemLoader.php(155): phpbb\template\twig\loader->findTemplate('index_body.html') #2 /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Environment.php(351): Twig\Loader\FilesystemLoader->getCacheKey('index_body.html') #3 /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Environment.php(445): Twig\Environment->getTemplateClass('index_body.html') #4 /homepages/26/d393251611/htdocs/foro/phpbb/template/twig/envi in /homepages/26/d393251611/htdocs/foro/vendor/twig/twig/src/Loader/FilesystemLoader.php on line 245


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 569
Registrado: 14 Ene 2017, 22:18
Nombre real: Alfredo
Ubicación: /dev/null
Género:
Contactar:

Error Fatal, no encuentra template....

Mensaje por AbaddonOrmuz » 05 Ago 2019, 21:06

Ya has solucionado el problema? No veo los errores en tu foro.

Intenta limpiar la caché manualmente, para ello elimina todo el contenido (archivos y carpetas) dentro de cache/production/

Si eso no soluciona tu problema, puedes desactivar la extensión Sortables Captcha desde phpMyAdmin ejecutando la siguiente consulta SQL (guía):

Código: Seleccionar todo

UPDATE phpbb_ext SET ext_active = 0 WHERE ext_name = 'derky/sortablescaptcha'
Luego de ello necesitarías limpiar la caché de forma manual nuevamente.
Algunas de mis extensiones: [ Imgur | Metadatos SEO | Markdown ]
Checa todas mi extensiones
Usuario de Arch Linux


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

JAR_AMD
Observador/a
Mensajes: 4
Registrado: 05 Ago 2019, 09:31
Nombre real: Jose
Género:

Error Fatal, no encuentra template....

Mensaje por JAR_AMD » 06 Ago 2019, 08:46

Conseguí solucionarlo, pero tuve ciertos problemas más.
Pienso que no fue la extensión Sortables Captcha, aunque ahora si es la que me está dando guerra. Creo que fue un problema del Estilo, algo se corrompio, pero el caso es que no se como.
A ver si me pongo a mirar algo más.

Ahora lo que tengo es problemas con el Sortable Captcha, la habilito y me salen errores PHP, tanto en el panel ACP al activarla en su apartado, como en la página de registro, pero bueno ya deja registrar y demás... aunque al no poder activarla ahora tengo ataques de SPAM... jajaja


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
andares
Moderador
Mensajes: 1154
Registrado: 18 Nov 2008, 03:32
Nombre real: Pedro
Ubicación: Barcelona
Género:
Contactar:

Error Fatal, no encuentra template....

Mensaje por andares » 06 Ago 2019, 15:30

La actual versión validada de "Sortables Captcha" tiene problemas con PHP 7.2.x y con phpBB 3.2.7, mejor utiliza la versión en desarrollo: https://github.com/Derky/Sortables-CAPT ... master.zip

Primero comprueba que la extensión te funciona correctamente con "prosilver", si no hay problema instala de nuevo el estilo "we_universal".

Ten en cuenta que "we_universal" necesita que "prosilver" este instalado y activo ya que "hereda" parte de sus plantillas (html) y hojas de estilo (css) para que funcione correctamente.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

JAR_AMD
Observador/a
Mensajes: 4
Registrado: 05 Ago 2019, 09:31
Nombre real: Jose
Género:

Error Fatal, no encuentra template....

Mensaje por JAR_AMD » 07 Ago 2019, 09:33

Pude solucionar lo del Sortables Captcha también, editando el código como indicaba en su día Derky. No se porque la primera vez que lo instale hice dicha modificación, pero después de que me fallara el foro, me descentre y se me olvido que había que modificarlo para que funcionara correctamente.
Ahora ya va todo, parece que no falla nada, no tengo SPAM y va todo bastante fluido.

Muchas gracias!!


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado
  • Temas similares
    Respuestas
    Vistas
    Último mensaje