Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

error HTTP al adjuntar IMAGENTema Solucionado

Foros de soporte phpBB 3.2


Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#16

Mensaje por J_Sparrow »

Pues o mucho me equivoco o la 3.2 que tienes instalada usa Php 7 y ese puede ser uno de tus problemas. Cámbiala a ver si se solucionan los problemas.


Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
petit79
PayPal
Mensajes: 125
Registrado: 12 May 2011, 22:32
Género:
Edad: 41

Re: error HTTP al adjuntar IMAGEN

#17

Mensaje por petit79 »

Pues creo que alli esta el problema, sino estoy equivocado la version 3.2 de phpbb requiere la 7.0
Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
Todtuga
Elite
Mensajes: 1000
Registrado: 27 Oct 2008, 01:02
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#18

Mensaje por Todtuga »

Segun estos requisitos para Phpbb3.2.x tienen que ser estos
2018-05-23_19-05-07.jpg
Y mi servidor tiene una version MAYOR la PHP 5.6.36 . Ya no entiendo nada! :(
Datos de soporte
Spoiler
URL: http://www.citroentuc.com.ar
Versión phpBB: 3.2.0-dev
Plantilla(s) usada(s): Prosilver
Servidor: Linux - Pago
Actualización desde otra versión: si desde la 3.0.12
Conversión desde otro sistema de foros: no
El infinito es escaso a nuestra existencia.
Extensiones o MODs Instalados:Activity Stats 1.2.3-DEV, Advanced BBCode Box 3.1.4., Announcements on index 1.0.1., Annual Stars 1.0.0., Board Announcements 1.0.6., Board Rules 1.0.4., Category Background Image 1.0.1, Fade header 1.1.5. , Google AdSense 1.0.0., Google Analytics 1.0.2., Google Translator 1.0.0., Lightbox 1.0.5., National Flags 2.1.3., Paypal Donation 1.0.3., PM Welcome 1.0.1., Poster IP in Viewtopic 1.0.2., Red title for new topic and new reply 1.0.2., Right Side Random Image 3.1.0., Site logo 1.0.0-b4., Thanks for posts 2.0.2., Upload Extensions 3.1.2., Youtube Videos Gallery 1.0.3.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
canidev
Moderador
Mensajes: 589
Registrado: 30 Jun 2011, 17:06
Género:
Edad: 33

Re: error HTTP al adjuntar IMAGEN

#19

Mensaje por canidev »

Este fallo puede deberse a muchos factores. En principio se puede descartar que sea por el tamaño del adjunto o por su extensión. (Daría otro error)
Casi apostaría a que tu foro está devolviendo un error 50x al procesar esa petición, pero es imposible solucionarlo sin obtener más datos y, la única forma que se me ocurre, es haciendo una prueba (a ver si consigo explicarme bien).

Justo antes de insertar el adjunto:
1. Abre la consola de errores (Herramientas para desarrolladores) de tu navegador (preferiblemente Chrome o Firefox), pestaña "Console".

2. En la barra de navegación del navegador (donde está la url del foro) borra esa url y pon esto:

Código: Seleccionar todo

javascript:phpbb.plupload.uploader.bind('Error', function(up,error){ console.log(error); });
y le das a enter. A simple vista no pasará nada, pero si.

3. Sube el adjunto. En el momento en que te de el error, en la consola de errores te aparecerá información relativa a este. A la izquierda tienes una flecha para poder desplegar la info y aparecen varias líneas (code, message, file, etc...) pero las 3 importantes son: response, status y responseHeaders y son esos los necesarios para determinar la posible causa del problema.
cap.png
PD: phpbb 3.2.2 funciona con phpbb 5.4 y superiores, se recomienda php 7 porque va mejor, pero con 5.6 funciona igualmente.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
Todtuga
Elite
Mensajes: 1000
Registrado: 27 Oct 2008, 01:02
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#20

Mensaje por Todtuga »

Me sale esto
2018-05-23_21-24-12.jpg
Datos de soporte
Spoiler
URL: http://www.citroentuc.com.ar
Versión phpBB: 3.2.0-dev
Plantilla(s) usada(s): Prosilver
Servidor: Linux - Pago
Actualización desde otra versión: si desde la 3.0.12
Conversión desde otro sistema de foros: no
El infinito es escaso a nuestra existencia.
Extensiones o MODs Instalados:Activity Stats 1.2.3-DEV, Advanced BBCode Box 3.1.4., Announcements on index 1.0.1., Annual Stars 1.0.0., Board Announcements 1.0.6., Board Rules 1.0.4., Category Background Image 1.0.1, Fade header 1.1.5. , Google AdSense 1.0.0., Google Analytics 1.0.2., Google Translator 1.0.0., Lightbox 1.0.5., National Flags 2.1.3., Paypal Donation 1.0.3., PM Welcome 1.0.1., Poster IP in Viewtopic 1.0.2., Red title for new topic and new reply 1.0.2., Right Side Random Image 3.1.0., Site logo 1.0.0-b4., Thanks for posts 2.0.2., Upload Extensions 3.1.2., Youtube Videos Gallery 1.0.3.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#21

Mensaje por J_Sparrow »

canidev escribió:PD: phpbb 3.2.2 funciona con phpbb 5.4 y superiores, se recomienda php 7 porque va mejor, pero con 5.6 funciona igualmente.
Creo que con hacer la prueba no va a perder nada, igual hasta se le acaban los problemas.
Pues tu dirás que funciona en 5.4, pero a mi me salían las líneas de código en la parte superior del Foro, no me dejaba entrar en ninguna configuración del ACP y fue cambiar a la versión 7.0 y se acabaron los problemas. Tu lo dices, se recomienda la 7 por que va mejor, pues yo no tardaría en hacer la prueba. ¿Que no sirve para nada?, por lo menos vas descartando posibles fallos.
@Todtuga , he visto que en otro lado comentas un error también con la aparición de líneas de código. Insisto, creo que es la versión de PHP, ya me perdonarás que insista, pero si no me hubiese pasado, no te lo diría.
Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
Todtuga
Elite
Mensajes: 1000
Registrado: 27 Oct 2008, 01:02
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#22

Mensaje por Todtuga »

Ya hice las pruebas pasando a PHP 7.0 y a la version PHP 7.1 . Previa desactivacion de todas las extensiones (al principio las dejé) y pasar al idioma Ingles y desactivar los estilos fuera del Prosilver. Me da ERROR GENERAL en ambos casos no me deja ni abrir la pagina inicial.

Código: Seleccionar todo

General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 55
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/cache/container_0374ec857381230fa83049643ce3cdee.php
LINE: 1233
CALL: phpbb\db\driver\mysql->sql_connect()

FILE: [ROOT]/vendor/symfony/dependency-injection/Container.php
LINE: 314
CALL: phpbb_cache_container->getDbal_Conn_DriverService()

FILE: [ROOT]/vendor/symfony/dependency-injection/ContainerBuilder.php
LINE: 447
CALL: Symfony\Component\DependencyInjection\Container->get()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 52
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\factory->get_driver()

FILE: [ROOT]/phpbb/config/db.php
LINE: 57
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/cache/container_0374ec857381230fa83049643ce3cdee.php
LINE: 587
CALL: phpbb\config\db->__construct()

FILE: [ROOT]/vendor/symfony/dependency-injection/Container.php
LINE: 314
CALL: phpbb_cache_container->getConfigService()

FILE: [ROOT]/vendor/symfony/dependency-injection/ContainerBuilder.php
LINE: 447
CALL: Symfony\Component\DependencyInjection\Container->get()

FILE: [ROOT]/cache/container_0374ec857381230fa83049643ce3cdee.php
LINE: 491
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

FILE: [ROOT]/vendor/symfony/dependency-injection/Container.php
LINE: 314
CALL: phpbb_cache_container->getCacheService()

FILE: [ROOT]/vendor/symfony/dependency-injection/ContainerBuilder.php
LINE: 447
CALL: Symfony\Component\DependencyInjection\Container->get()

FILE: [ROOT]/includes/compatibility_globals.php
LINE: 22
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

FILE: [ROOT]/common.php
LINE: 109
CALL: require('[ROOT]/includes/compatibility_globals.php')

FILE: [ROOT]/index.php
LINE: 23
CALL: include('[ROOT]/common.php')

Datos de soporte
Spoiler
URL: http://www.citroentuc.com.ar
Versión phpBB: 3.2.0-dev
Plantilla(s) usada(s): Prosilver
Servidor: Linux - Pago
Actualización desde otra versión: si desde la 3.0.12
Conversión desde otro sistema de foros: no
El infinito es escaso a nuestra existencia.
Extensiones o MODs Instalados:Activity Stats 1.2.3-DEV, Advanced BBCode Box 3.1.4., Announcements on index 1.0.1., Annual Stars 1.0.0., Board Announcements 1.0.6., Board Rules 1.0.4., Category Background Image 1.0.1, Fade header 1.1.5. , Google AdSense 1.0.0., Google Analytics 1.0.2., Google Translator 1.0.0., Lightbox 1.0.5., National Flags 2.1.3., Paypal Donation 1.0.3., PM Welcome 1.0.1., Poster IP in Viewtopic 1.0.2., Red title for new topic and new reply 1.0.2., Right Side Random Image 3.1.0., Site logo 1.0.0-b4., Thanks for posts 2.0.2., Upload Extensions 3.1.2., Youtube Videos Gallery 1.0.3.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
canidev
Moderador
Mensajes: 589
Registrado: 30 Jun 2011, 17:06
Género:
Edad: 33

Re: error HTTP al adjuntar IMAGEN

#23

Mensaje por canidev »

Pues tu dirás que funciona en 5.4, pero a mi me salían las líneas de código en la parte superior del Foro, no me dejaba entrar en ninguna configuración del ACP y fue cambiar a la versión 7.0 y se acabaron los problemas.
Concretamente, necesita php 5.4.7. Igual probaste con una versión inferior. De todas formas, no recomendaría usar una versión inferior a php 5.6
Ya hice las pruebas pasando a PHP 7.0 y a la version PHP 7.1 . Previa desactivacion de todas las extensiones (al principio las dejé) y pasar al idioma Ingles y desactivar los estilos fuera del Prosilver. Me da ERROR GENERAL en ambos casos no me deja ni abrir la pagina inicial.
Eso es porque usas mysql en lugar de mysqli (en php7 está obsoleto)
En el config.php, en el parámetro "$dbms" cambia "mysql" por "mysqli" para evitar ese error

Esta prueba puedes hacerla, pero no creo que sea el motivo, yo me decanto más porque haya algún fallo de la actualización o que no estés usando los archivos correspondientes a la versión de phpbb instalada.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
Todtuga
Elite
Mensajes: 1000
Registrado: 27 Oct 2008, 01:02
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#24

Mensaje por Todtuga »

canidev escribió:
25 May 2018, 16:44
Eso es porque usas mysql en lugar de mysqli (en php7 está obsoleto)
En el config.php, en el parámetro "$dbms" cambia "mysql" por "mysqli" para evitar ese error
Ya lo hice pero ese ERROR GENERAL continúa. Asi que lo dejé con PHP 5.6
canidev escribió:
25 May 2018, 16:44
Esta prueba puedes hacerla, pero no creo que sea el motivo, yo me decanto más porque haya algún fallo de la actualización o que no estés usando los archivos correspondientes a la versión de phpbb instalada.
Estoy de acuerdo contigo. Pero ...¿como hago para saber cuales son los archivos que corresponden a esta falla?... asi los busco entre las copias que tengo y los pongo.
Datos de soporte
Spoiler
URL: http://www.citroentuc.com.ar
Versión phpBB: 3.2.0-dev
Plantilla(s) usada(s): Prosilver
Servidor: Linux - Pago
Actualización desde otra versión: si desde la 3.0.12
Conversión desde otro sistema de foros: no
El infinito es escaso a nuestra existencia.
Extensiones o MODs Instalados:Activity Stats 1.2.3-DEV, Advanced BBCode Box 3.1.4., Announcements on index 1.0.1., Annual Stars 1.0.0., Board Announcements 1.0.6., Board Rules 1.0.4., Category Background Image 1.0.1, Fade header 1.1.5. , Google AdSense 1.0.0., Google Analytics 1.0.2., Google Translator 1.0.0., Lightbox 1.0.5., National Flags 2.1.3., Paypal Donation 1.0.3., PM Welcome 1.0.1., Poster IP in Viewtopic 1.0.2., Red title for new topic and new reply 1.0.2., Right Side Random Image 3.1.0., Site logo 1.0.0-b4., Thanks for posts 2.0.2., Upload Extensions 3.1.2., Youtube Videos Gallery 1.0.3.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#25

Mensaje por J_Sparrow »

Todtuga escribió:Ya hice las pruebas pasando a PHP 7.0 y a la version PHP 7.1
Gracias @Todtuga , si lo has hecho y no funciona, mucho mas no puedo aconsejarte. Intento ayudar en lo que puedo y si se me ocurre algo, aunque sea muy disparatado, lo suelto, a ver si se soluciona el problema o le iluminamos a algún experto para darte una idea mejor.
A ver si con lo que dice @canidev , consigues algo.
Gracias @canidev , por tu aclaración, que estoy seguro es la correcta. Yo no tengo mucha idea de PHP, pero estoy seguro de que tu lo conoces bastante mas que yo y sabes muy bien lo que dices. No seré yo quien pueda discutirte :D :x :x
Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
Todtuga
Elite
Mensajes: 1000
Registrado: 27 Oct 2008, 01:02
Género:
Edad: 59

Re: error HTTP al adjuntar IMAGEN

#26

Mensaje por Todtuga »

Ahi pude con la version PHP "7.1" con la modificación en el parámetro "$dbms" cambié "mysql" por "mysqli", abre bien el foro pero cuando quiero entrar a cualquier tema me los abre pero me salta el DEBUG en la parte superior con el siguiente contenido:

Código: Seleccionar todo

[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 370: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5312: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3925)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5312: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3925)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5312: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3925)
Datos de soporte
Spoiler
URL: http://www.citroentuc.com.ar
Versión phpBB: 3.2.0-dev
Plantilla(s) usada(s): Prosilver
Servidor: Linux - Pago
Actualización desde otra versión: si desde la 3.0.12
Conversión desde otro sistema de foros: no
El infinito es escaso a nuestra existencia.
Extensiones o MODs Instalados:Activity Stats 1.2.3-DEV, Advanced BBCode Box 3.1.4., Announcements on index 1.0.1., Annual Stars 1.0.0., Board Announcements 1.0.6., Board Rules 1.0.4., Category Background Image 1.0.1, Fade header 1.1.5. , Google AdSense 1.0.0., Google Analytics 1.0.2., Google Translator 1.0.0., Lightbox 1.0.5., National Flags 2.1.3., Paypal Donation 1.0.3., PM Welcome 1.0.1., Poster IP in Viewtopic 1.0.2., Red title for new topic and new reply 1.0.2., Right Side Random Image 3.1.0., Site logo 1.0.0-b4., Thanks for posts 2.0.2., Upload Extensions 3.1.2., Youtube Videos Gallery 1.0.3.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
andares
Moderador
Mensajes: 1402
Registrado: 18 Nov 2008, 03:32
Género:
Edad: 54

Re: error HTTP al adjuntar IMAGEN

#27

Mensaje por andares »

@Todtuga, error tipico de estar usando archivos de phpBB 3.1.x el cual no es compatible con PHP 7.0/7.1, solo phpBB 3.2 es compatible con PHP 7.0/7.1

La verdad es que ya no sabemos como explicarte y de que tú lo entiendas, que la base de datos que estan utilizando "3.2.0-dev" es el resultado de una actualización erronea por lo cual es impredecible los errores que puede causar o derivar, por eso nosotros y en el foro oficial ingles te aconsejamos que vuelvas a la misma versión con la que empezaste la actualización...

En el caso de que no puedas volver por una copia de seguridad de la base de datos erronea de la 3.1.x siempre puedes recurrir a que tu hosting te proporcione una copia.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
canidev
Moderador
Mensajes: 589
Registrado: 30 Jun 2011, 17:06
Género:
Edad: 33

Re: error HTTP al adjuntar IMAGEN

#28

Mensaje por canidev »

@Todtuga, error tipico de estar usando archivos de phpBB 3.1.x el cual no es compatible con PHP 7.0/7.1, solo phpBB 3.2 es compatible con PHP 7.0/7.1
100% de acuerdo.

@Todtuga Lo que te dice @andares de restaurar el foro a su versión 3.1.x sería una opción, pero me imagino que, dado el tiempo que hace que actualizaste, perderás datos haciéndolo (mensajes / usuarios).
Entonces, para no perder nada, lo que te recomiendo hacer es asegurarte de usar los archivos correspondientes a la versión que tienes (3.2.0-dev). Justo los del dev creo que no están disponibles, pero de la 3.2.0 si.

Para hacerlo:
1. Haz copia de seguridad, por si acaso.
2. Descarga el paquete completo de phpbb 3.2.0
https://sourceforge.net/projects/phpbb- ... p/download

3. De tu foro, elimina todo excepto las carpetas ext, files, images, store y el archivo config.php. Estes 5 elementos son los únicos que tienen que quedarte.
4. Extrae el contenido del zip de phpbb 3.2.0 en tu ordenador y elimina el config.php de ahí (porque ese está vacío y ya has dejado el original en el server, que es el que se usará)
5. Sube esos archivos restantes al server, quedándote tal y como estaban los otros
6. Reza un par de oraciones para que todo funcione bien ahora, eso siempre viene bien :shock:

PD: @J_Sparrow lo de la versión está sacado de la documentación oficial de phpBB. Yo personalmente no lo he probado en 5.4. Igual hago mal en fiarme de esa documentación y soy yo el equivocado :!:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
andares
Moderador
Mensajes: 1402
Registrado: 18 Nov 2008, 03:32
Género:
Edad: 54

Re: error HTTP al adjuntar IMAGEN

#29

Mensaje por andares »

@canidev , yo creo que antes de proceder a eso seria aconsejable que revisase en que estado tiene la base de datos desde phpMyAdmin, analizando todas las tablas y si el resultado es positivo tendria mas posibilidades a que le funcionase lo que le has comentado, ahora bien si es negativo ya seria cuestion de contactar con su hosting para una copia...


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
canidev
Moderador
Mensajes: 589
Registrado: 30 Jun 2011, 17:06
Género:
Edad: 33

Re: error HTTP al adjuntar IMAGEN

#30

Mensaje por canidev »

@canidev , yo creo que antes de proceder a eso seria aconsejable que revisase en que estado tiene la base de datos desde phpMyAdmin, analizando todas las tablas y si el resultado es positivo tendria mas posibilidades a que le funcionase lo que le has comentado, ahora bien si es negativo ya seria cuestion de contactar con su hosting para una copia...
Si, pero seguramente no tenga ninguna tabla "rota" como tal. (Si la tuviese no le funcionaría el foro casi seguro)
Lo que puede es que falten columnas o haya datos con un formato incorrecto, y la única forma de saberlo sería comparar la base de datos de un foro phpbb 3.2.0 recién instalado con la suya, y ver las diferencias en la estructura de las tablas y datos. Y no hay ninguna herramienta que lo haga y a mano te puedes morir en el intento.
Por eso menciono lo de hacer copia de seguridad, si ese proceso no le sirve, siempre puede volver al punto actual.

Resumiendo. Las opciones que yo veo son:
1. Volver a una copia anterior que se sepa que funcionase, y perder los mensajes/usuarios creados después de ese punto.
2. Hacer el proceso que menciono en el anterior mensaje, a ver si hay suerte.
3. Buscar la forma de completar la actualización a 3.2.2 (aunque partiendo de la base de una actualización a medias, tampoco hay el 100% de posibilidades de que todo funcione bien después)


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.2”