Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Problemas al actualizar a 3.2Tema Solucionado

Foros de soporte phpBB 3.2


Avatar de Usuario
eportugues
Usuario/a
Mensajes: 63
Registrado: 25 Jun 2006, 19:47
Género:
Edad: 38

Problemas al actualizar a 3.2

#1

Mensaje por eportugues »

URL: (web506.com/foro/)
Estilo(s) usuado(s): prosilver
MODs/Extensiones instaladas: -
Versión de phpBB: 3.1 a 3.2
Tu conocimiento: Medio-Avanzado
Servidor: (vps godaddy)
Es una actualización desde otra versión: (de 3.1 a 3.2 actualizacion automatica)

Se me ha presentado un problema a la hora de actualizar mi foro de 3.1 a 3.2.

He hecho todo lo debido previo a su actualización (respaldo, desactivar mods, cambiar a prosilver, cambiar a inglés, reemaplazar archivos a los del 3.2, etc).

A la hora de ir a "/install/", los primeros pasos transcurren con normalidad, pero llego a un punto en que se cae la instalación y me muestra lo siguiente:

Imagen

Tengo un respaldo de mi base de datos cuando lo tuve en 3.1.

El foro me ingresa normalmente y puedo navegar al panel de administración, mostrando lo siguiente:

Imagen

Lo cual significa que mi base de datos no está al día, pero no me permite realizarla correctamente.

¿Alguna idea?




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Re: Problemas al actualizar a 3.2

#2

Mensaje por J_Sparrow »

No soy ningún experto, pero viendo tus imágenes, creo que se lo que te pasa.
Dices que puedes entrar en el ACP (Panel de Administración) y que crees que te da un error, lo que no se es por que te sale el Panel en inglés, me imagino que tu Foro esta en castellano, así que el panel debería estar en el mismo idioma. Y si, te da un error, que no es un error, es un aviso (mejor dicho DOS avisos:
  • Te dice que hay una nueva versión, la 3.2.2, y que te actualices. Yo te recomiendo que de momento no lo hagas.
  • Te esta diciendo que renombres o borres el directorio install que hay en tu Foro para que sea accesible al resto de usuarios. Esto lo has de hacer a través de una FTP o a través de tu servidor. Es tan simple como accedes a donde tu servidor guarda los ficheros de tu Foro, buscar el directorio que te comento y ponerle delante unas XXX. Te lo recomiendo antes de borrarlo, porque si quieres hacer alguna cosa mas, puede que necesites este directorio. Luego ya lo borrarás.
Si que parece que tengas algún problema con la Base de Datos, pero como no nos muestras mas imágenes, no podemos adivinar que es lo que pasa. No se, puede que sea que has instalado una versión que no logro reconocer, la 3.2.0-a2, cuando esta la 3.2.1
Puede que al instalar esa versión, te de ese primer problema. Insisto, al no estar el panel en castellano, te puede confundir. Intenta instalar la versión 3.2.1, aunque yo primero renombraría el directorio install para ver si puedes acceder de manera normal al Foro.
Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
eportugues
Usuario/a
Mensajes: 63
Registrado: 25 Jun 2006, 19:47
Género:
Edad: 38

Re: Problemas al actualizar a 3.2

#3

Mensaje por eportugues »

Gracias por la respuesta, te comento un poco a partir de lo que me dices.

- Lo del idioma no es problema, lo tengo en British porque hice la conversión de 3.1 a 3.2.
- El directorio install aún lo tengo porque estoy en plena actualización y el problema muy reciente. Lo puedo renombrar en cualquier momento pero eso no me soluciona el fallo.

El panel admin me muestra el siguiente mensaje:

"Your phpBB installation has not been correctly updated."

Lo que significa que mi base de datos no está actualizada.

Al intentar 'subir' los archivos para convertir mi base de datos a 3.2 y empezar el paso a paso en "/install/", el mensaje que me muestra el panel de administración es el siguiente:

Imagen

A lo cual veo que hay un problema en la tabla "phpbb_oauth_accounts" (mi base de datos se llama "web506ft_CH8B")
General Error:SQL ERROR [ mysqli ]Table 'web506ft_CH8B.phpbb_oauth_accounts'
Gracias por cualquier ayuda que pueda solucionar esto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Re: Problemas al actualizar a 3.2

#4

Mensaje por J_Sparrow »

Bueno, con esos mensajes ya no te puedo ayudar, no es mi fuerte. Pero permite que siga insistiendo, ¿por que no actualizas a la 3.2.1 directamente?. No te aseguro que no te vayan a salir esos mensajes, pero tarde o temprano lo has de hacer. La versión que estas intentando instalar es una versión provisional si no me equivoco, una versión correctora de posibles fallos anteriores. Yo las llamo "provisionales" y cuando no me queda mas remedio que usarlas, las uso, pero si puedo elegir otra superior, ni lo dudo.
De todas formas, si esperas un poco, seguro que un buen experto te dará alguna idea de lo que pasa o tal vez una solución mejor que la mía.
Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
canidev
Moderador
Mensajes: 590
Registrado: 30 Jun 2011, 17:06
Género:
Edad: 33

Re: Problemas al actualizar a 3.2

#5

Mensaje por canidev »

Hola

Por el mensaje de error que te aparece, es como si faltase una tabla en la base de datos (tabla que debería existir en la versión 3.1)
Yo, lo que haría sería añadirla directamente en la base de datos (a través de phpmyadmin) y después continuar la instalación.
Para hacerlo, abre phpmyadmin, entra en la base de datos, revisa si la tabla "phpbb_oauth_accounts" existe.
Si no existe, en la pestaña SQL inserta lo siguiente:

Código: Seleccionar todo

CREATE TABLE `phpbb_oauth_accounts` (
  `user_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
  `provider` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `oauth_provider_id` text COLLATE utf8_bin NOT NULL
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_bin;

ALTER TABLE `phpbb_oauth_accounts`
  ADD PRIMARY KEY (`user_id`,`provider`);

Sobre el tema de que aparezca la versión 3.0.2-a2 en el ACP es normal cuando se queda a medias.
Al hacer una actualización, el instalador va versión por versión introduciendo los cambios (no pasa de golpe de 3.1 a 3.2.1). Por ese motivo, cuando se para, la versión se queda en el punto en el que se haya quedado el instalador.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
eportugues
Usuario/a
Mensajes: 63
Registrado: 25 Jun 2006, 19:47
Género:
Edad: 38

Re: Problemas al actualizar a 3.2  Tema Solucionado

#6

Mensaje por eportugues »

Gracias @canidev, efectivamente me hacía falta la tabla que mencionas.

Mi instalación era desde 3.1.10 a 3.2.2 y por una extraña razón, tanto phpbb_oauth_accounts, como phpbb_oauth_tokens no estaban generadas en mi base de datos (pensé que se creaban en 3.2).

Incluí ambas antes de hacer la actualización y ahora si solucionado.

Gracias nuevamente.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.2”