Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Problema con pagina personalizadaTema Solucionado

Foros donde podréis dejar vuestras dudas sobre phpBB 3.0.x
Cerrado

0
No hay votos
 
Votos totales: 0

Avatar de Usuario
elchiky77
Usuario/a
Mensajes: 96
Registrado: 20 Dic 2006, 23:48

Problema con pagina personalizada

#1

Mensaje por elchiky77 » 30 Ago 2010, 22:24

Que tal gente, siguiendo este tutorial: http://www.phpbb-es.com/foro/paginaphpbb3 empeze a hacer paginas personalizadas, pero tengo un problema:

Código: Seleccionar todo

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4209: Cannot modify header information - headers already sent by (output started at /cs_servers.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4211: Cannot modify header information - headers already sent by (output started at /cs_servers.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4212: Cannot modify header information - headers already sent by (output started at /cs_servers.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4213: Cannot modify header information - headers already sent by (output started at /cs_servers.php:1)
Eso aparece en el top de la web.

Aca les dejo las paginas asi pueden entender un poco mas:

/includes/functions.php
Spoiler
Mostrar
line4209 header('Content-type: text/html; charset=UTF-8');

line4211 header('Cache-Control: private, no-cache="set-cookie"');
line4212 header('Expires: 0');
line4213 header('Pragma: no-cache');
Mi pagina personalizada:
cs_servers.php
Spoiler
Mostrar
<?php
define('IN_PHPBB', true);
$phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : './';
$phpEx = substr(strrchr(__FILE__, '.'), 1);
include($phpbb_root_path . 'common.' . $phpEx);

// Start session management
$user->session_begin();
$auth->acl($user->data);
$user->setup();

page_header('Mi página');

$template->set_filenames(array(
'body' => 'cs_servers.html',
));

make_jumpbox(append_sid("{$phpbb_root_path}viewforum.$phpEx"));
page_footer();
?>[/code]

cs_servers.html
Spoiler
Mostrar
<!-- INCLUDE overall_header.html -->

<h2>Servers Counter-Strike 1.6</h2>

<div class="panel">
<div class="inner"><span class="corners-top"><span></span></span>

<div class="content">
<p>

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css">
<!--
.Estilo1 {font-family: Arial, Helvetica, sans-serif}
.Estilo9 {font-size: 26px; font-weight: bold; color: #0066FF; }
.Estilo10 {color: #000000}
.Estilo11 {font-size: 26px; font-weight: bold; color: #000000; }
-->
</style>
</head>

<body>
<center>
<table width="90%" border="0" align="center">
<tr>
<td><table width="100%" border="0">
<tr>
<td><div align="center" class="Estilo1">
<div align="center">
<p><br>
<strong>Elemental Servers # 1 [Publico/Mix]:</strong><br>
<span class="Estilo9"><span class="Estilo10">200.43.193.111:27020</span><br>
</span></p>
</div>
</div></td>
<td><div align="center" class="Estilo1">
<div align="center">
<p><br>
<strong>Elemental Servers # 2 [Publico/Mix]:</strong><br>
<span class="Estilo11">200.43.193.95:27017</span></p>
</div>
</div></td>
</tr>
<tr>
<td><div align="center"><span class="Estilo1">
<iframe src="http://cache.www.gametracker.com/compon ... &width=250" frameborder="0" scrolling="no" width="250" height="412"></iframe>
</span></div></td>
<td><div align="center"><span class="Estilo1">
<iframe src="http://cache.www.gametracker.com/compon ... &width=250" frameborder="0" scrolling="no" width="250" height="412"></iframe>
</span></div></td>
</tr>
<tr>
<td><div align="center"><span class="Estilo1"></span></div></td>
<td><div align="center"><span class="Estilo1"></span></div></td>
</tr>
</table>
<p align="center" class="Estilo1"><a href="cs_admin.php">Alquiler de Admin </a></p>
<p align="center" class="Estilo1"><a href="cs_descargas.php">Descargar Counter-Strike </a></p></td>
</tr>
</table>
</center>
</body>
</html>

</p>
</div>
</div>
</div>

<!-- INCLUDE jumpbox.html -->
<!-- INCLUDE overall_footer.html -->

Probe borrando la linea del cs_server.php:

Código: Seleccionar todo

        page_header('Mi página');
El debug desaparece, pero la pagina pierde totalmente el estilo.


Podrian ayudarme? es de mucha importancia y urgente!

Gracias como siempre a todos


URL: http://www.elementalservers.com.ar
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Ninguno
Servidor: Nuthost.com
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
jakk
Ex Staff
Mensajes: 2202
Registrado: 14 Jun 2009, 08:57
Nombre real: Ivan
Ubicación: La Coruña
Edad: 34
Contactar:

Re: Problema con pagina personalizada

#2

Mensaje por jakk » 31 Ago 2010, 00:00

si no podemos ver tu foro no podemos darte soporte
Antes de nada, lee las Normas de phpBB-Es, y el siempre útil Foro de guías sobre phpBB 3.
Consulta la Documentación de phpBB 2 y phpBB 3 y sus correspondientes FAQS de ayuda.
Administra, modifica, actualiza tu foro con el listado de Guías de nuestra Biblioteca.
Quizás tu duda esté resuelta, y todos ahorremos tiempo.
Si es sobre cómo Crear una Consulta SQL ya lo tienes explicado en el enlace.
En general, se recomienda Buscar antes de preguntar para no repetir preguntas y dudas resueltas.
Sólo tendrás Soporte si facilitas los datos correspondientes y si respetas completamente el Copyright de phpBB.
NOTA: No damos Soporte a los foros integrados en Nuke y derivados del mismo. Infórmate AQUÍ.

[hr]
No doy soporte por MP ni por MSN ni por el Chat
[hr]
© Jakk - www.ivemfinity.com | © chirri23 - www.mundoforeros.com | Foro de Pruebas


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
elchiky77
Usuario/a
Mensajes: 96
Registrado: 20 Dic 2006, 23:48

Re: Problema con pagina personalizada

#3

Mensaje por elchiky77 » 31 Ago 2010, 00:29

jakk escribió:si no podemos ver tu foro no podemos darte soporte
Ok, este es el link del problema: http://www.elementalservers.com.ar/foro/cs_servers.php
URL: http://www.elementalservers.com.ar
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Ninguno
Servidor: Nuthost.com
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
elchiky77
Usuario/a
Mensajes: 96
Registrado: 20 Dic 2006, 23:48

Re: Problema con pagina personalizada

#4

Mensaje por elchiky77 » 31 Ago 2010, 21:59

porfavor alguien que me de una mano?
la raiz de foro es: http://www.elementalservers.com.ar/foro/
URL: http://www.elementalservers.com.ar
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Ninguno
Servidor: Nuthost.com
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
nextgen
Elite
Mensajes: 1718
Registrado: 25 Jul 2009, 03:16
Nombre real: Melvin
Ubicación: Guatemala, Guatemala
Género:
Edad: 36
Contactar:

Re: Problema con pagina personalizada

#5

Mensaje por nextgen » 01 Sep 2010, 05:45

primero coloca el copyright del idioma :ok:
Inactivo...


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
elchiky77
Usuario/a
Mensajes: 96
Registrado: 20 Dic 2006, 23:48

Re: Problema con pagina personalizada

#6

Mensaje por elchiky77 » 01 Sep 2010, 19:48

nextgen escribió:primero coloca el copyright del idioma :ok:
listo, ya lo agregue, no sabia que no podia sacarlo.
Podrian ayudarme? es urgente :(
URL: http://www.elementalservers.com.ar
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Ninguno
Servidor: Nuthost.com
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
nextgen
Elite
Mensajes: 1718
Registrado: 25 Jul 2009, 03:16
Nombre real: Melvin
Ubicación: Guatemala, Guatemala
Género:
Edad: 36
Contactar:

Re: Problema con pagina personalizada

#7

Mensaje por nextgen » 01 Sep 2010, 20:06

en que editor guardaste los archivos?, guardalos utilizando el notepad++ en formato UTF-8 sin BOOM
Inactivo...


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Alorse
Ex Staff
Mensajes: 5144
Registrado: 22 Mar 2008, 02:14
Nombre real: Alfredo
Ubicación: Colombia
Género:
Edad: 31
Contactar:

Re: Problema con pagina personalizada  Tema Solucionado

#8

Mensaje por Alorse » 01 Sep 2010, 20:16

En el archivo cs_servers.php, fíjate que no hallan espacios en blanco antes del "<?php", muchas veces el error suele ser a causa de esto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
elchiky77
Usuario/a
Mensajes: 96
Registrado: 20 Dic 2006, 23:48

Re: Problema con pagina personalizada

#9

Mensaje por elchiky77 » 01 Sep 2010, 21:41

Alorse escribió:En el archivo cs_servers.php, fíjate que no hallan espacios en blanco antes del "<?php", muchas veces el error suele ser a causa de esto.
PERFECTO!
muchas gracias a todos
URL: http://www.elementalservers.com.ar
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Ninguno
Servidor: Nuthost.com
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
elchiky77
Usuario/a
Mensajes: 96
Registrado: 20 Dic 2006, 23:48

Re: Problema con pagina personalizada

#10

Mensaje por elchiky77 » 01 Sep 2010, 22:52

Aprovecho el post para hacer una nueva consulta. puedo crear una pagina personalizada, pero que al abrirla se abra en el sector del medio del portal.. es decir, en el sector que esta marcado en esta foto:

Imagen
URL: http://www.elementalservers.com.ar
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Ninguno
Servidor: Nuthost.com
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Alorse
Ex Staff
Mensajes: 5144
Registrado: 22 Mar 2008, 02:14
Nombre real: Alfredo
Ubicación: Colombia
Género:
Edad: 31
Contactar:

Re: Problema con pagina personalizada

#11

Mensaje por Alorse » 02 Sep 2010, 02:49

Abre un nuevo tema compañero!!!


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado

Volver a “Foros de Soporte 3.0.x”