Página 1 de 2

Error al actualizar de 3.2.5 a 3.2.7  Tema Solucionado

Publicado: 15 Jul 2019, 19:00
por Tio Javi

Datos de Soporte - Inicio

URL: www.partieron.cl (del sitio en cuestión)
Estilo(s) usuado(s): Flat Style (del sitio en cuestión)
MODs/Extensiones instaladas: (en el sitio en cuestión)
Versión de phpBB:3.2.7 (cambia de versión, en caso que no uses esa claro esta).
Versión de PHP en tu servidor:7.2.7 (cambia de versión, si es otra en tu servidor).
Tipo de base de datos y versión en tu servidor:libmysql - 5.1.73 (cambia de nombre, si es otra en tu servidor).

Tu conocimiento: Conocimiento básico
Servidor: de pqago (del sitio en cuestión, si es de pago, gratuito, etc.)
Es una actualización desde otra versión: de 3.2.5 a 3.2.7 (especificar versión anterior y versión de actualización)
Es una conversión desde otro tipo de Foro: NO (especificar sistema de foro anterior y versión del nuevo)

Datos de Soporte - Fin

Actualicé descargando paquete desde la web de phpbb y al terminar, la página arroja error 500. Voy a ver el archivo error_log y esto aparece:

Código: Seleccionar todo

[15-Jul-2019 16:55:06 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:06 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:06 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:06 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:06 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:06 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:07 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:08 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/partiero/public_html/phpBB3/ext/phpbb/mediaembed/event/main_listener.php(90): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/partiero/public_html/phpBB3/vendor/symfony/event-dispatcher/EventD in /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[15-Jul-2019 16:55:11 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:11 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:11 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:16 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:17 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:17 UTC] PHP Warning:  require(../install/startup.php): failed to open stream: No such file or directory in /home/partiero/public_html/phpBB3/app.php on line 30
[15-Jul-2019 16:55:17 UTC] PHP Fatal error:  require(): Failed opening required '../install/startup.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/partiero/public_html/phpBB3/app.php on line 30

Favor vuestra ayuda ya que el sitio está caído.

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 19:21
por J_Sparrow
¿Puedes explicarnos como has hecho la actualización?, me refiero ha si has subido los archivos por ftp a tu servidor, si has hecho una copia previa de la base de datos, si has desactivado las extensiones y si has ejecutado el install. Yo de momento poco mas puedo hacer por ti.

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 20:07
por Tio Javi
Subí el paquete de actualización al servidor y lo ejecuté (con la tura\install...). Terminó sin problemas ni errores y luego la web no volvió más. Las extensiones no las deshabilité.

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 20:15
por J_Sparrow
Tio Javi escribió:
15 Jul 2019, 20:07
Las extensiones no las deshabilité.
Pues mira, ya tenemos un primer problema. Puede que tengas alguna extensión incompatible con la nueva versión y sea uno de los problemas.
Desactiva todas las extensiones desde el ACP y vuelve a probar si te funciona tu Foro. Si funciona, vete activando una por una hasta dar con la que es incompatible. Si no te funciona, a ver si algún compañero te puede ayudar algo mas.

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 20:24
por Tio Javi
No logro ingresar a http://www.partieron.cl/phpBB3/adm/index.php

Asumo esa es la dirección para ingresar al Panel de Control. no?

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 20:40
por J_Sparrow
Si, esa es, pero ahora que lo pienso, si no puedes acceder a la página, no podrás entrar en el panel. Tendrás que desactivar las extensiones desde phpMyAdmin, vamos, desde el panel de tu servidor. Hay un post por aquí que dice como desactivar las extensiones desde donde te digo, creo que es buscar la tabla en la base de datos y cambiarle los valores de 1 a 0
Pero tampoco te aseguro que esto solucione tu problema.

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 20:42
por Tio Javi
Qué cagada...

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 21:50
por J_Sparrow
Tranquilo, todo tiene solución, además, así se aprende algo, te lo digo por experiencia propia.
Aunque este caído tu sitio unos días, no pasa nada. A ver si se conecta alguno de los grandes expertos de este Foro y te puede ayudar. Yo se lo justo y no se me ocurre gran cosa. no se si has buscado por el Foro, quiero recordar que errores como este ya han pasado a otros.
Y recuerda, antes de hacer nada, lo primero y mas importante, hacer una copia de la Base de Datos, algo que yo no hice en su día (aunque pensaba que si y no comprobé que estaba bien) y que me costó un dinero el que mi servidor me la recuperase. Ya he aprendido. Luego también te recomiendo que primero busques guías de como se hacen las cosas, aunque pienses que sabes hacerlo. Cualquier pequeño detalle para los que no controlamos estos temas, nos conducen a estos pequeños desastres.

Animo, pronto pondrás en marcha tu Foro de nuevo.

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 21:57
por AbaddonOrmuz
Ya has limpiado la caché?

Si la base de datos ya ha sido actualizada, intenta limpiar los archivos de phpBB. Pero antes de comenzar, como comenta mi compañero @J_Sparrow, crea una copia de seguridad de la base de datos.

Para ello, sigue la guía Actualizando phpBB 3.2.x hasta el paso 7 y el 10 (ignora los pasos 8 y 9), pero usando el paquete completo en español (paso 3):

db/converter/phpbb_espa%C3%B1ol/

Luego de ello limpia la cache manualmente (desde FTP o SSH), esto es, elimina todos los archivos y carpetas dentro de cache/production/

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 15 Jul 2019, 22:08
por J_Sparrow
Por cierto, pregunta tonta, ¿has renombrado la carpeta install a través de la FTP?, si no no puedes acceder al Foro. La borras o la renombras, lo que quieras, pero mientras exista esa carpeta, no puedes acceder al Foro.

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 16 Jul 2019, 00:45
por Tio Javi
El paquete completo de 3.2.7 está erróneo en la web. Otra dirección de donde descargarlo? O puedo subir los archivos del paquete original en inglés?

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 16 Jul 2019, 01:02
por Tio Javi
Seguí las instrucciones, subí los archivos del paquete completo original (el archivo en español está erróneo) y sigo caído. El error que aparece en error_log ahora es:

Código: Seleccionar todo

[15-Jul-2019 22:58:51 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/partiero/public_html/phpBB3/ext/phpbb/mediaembed/event/main_listener.php(90): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/partiero/public_html/phpBB3/vendor/symfony/event-dispatcher/EventD in /home/partiero/public_html/phpBB3/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 16 Jul 2019, 03:47
por AbaddonOrmuz
Tus datos de soporte no indican qué extensiones tienes activadas actualmente, es un dato importante.
Tio Javi escribió:
16 Jul 2019, 01:02
... phpBB3/ext/phpbb/mediaembed/ ...
Puedes deshabilitar la extensión Media Embed, que al parecer es la que da problemas, desde phpMyAdmin (guía):

Código: Seleccionar todo

UPDATE phpbb_ext SET ext_active = 0 WHERE ext_name = 'phpbb/mediaembed'
Luego de ello, es muy importante que limpies la caché nuevamente.

Cuando recobres acceso a tu PCA, actualiza la extensión Media Embed, porque la versión que tienes parece ya no ser compatible.
Tio Javi escribió:
16 Jul 2019, 00:45
El paquete completo de 3.2.7 está erróneo en la web
A qué te refieres con que esta erróneo?

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 16 Jul 2019, 04:10
por Tio Javi
Eres EXTRAORDINARIO!!! Logré deshabilitar la extensión desde phpMyAdmin y volvió el sitio.

Gracias maestro!!

Error al actualizar de 3.2.5 a 3.2.7

Publicado: 16 Jul 2019, 04:11
por Tio Javi
Me refiero a que la versión está errónea pues al descargarla, el .zip no abre.