Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

No se envian correos desde phpbb

Foros de soporte phpBB 3.3


chokie
Observador/a
Mensajes: 26
Registrado: 24 Ago 2014, 20:52

No se envian correos desde phpbb

#1

Mensaje por chokie »

Buenos días. Expongo mi caso.

Hasta hace una semana, tenía mi hosting en: Hostinger (Que tenía GSuite integrado), recientemente me he pasado a: Profesionalhosting (Que no tiene GSuite integrado). Bien, después de redirigir los DNS (MX y TXT) a GSuite, el correo de manera externa recibe y envía correos sin problema. Pero cuando los tiene que enviar PhpBB, no los envía. Tengo la misma configuración de SMTP que tenía anteriormente, por lo que nada de eso ha cambiado.

Alguien tiene alguna idea de por qué no envía desde PhpBB?

Muchas gracias por vuestra ayuda.



Datos de Soporte

URL: https://www.fuerzasarmadas.eu
Estilo usuado: Base Prosilver
Extensiones instaladas:

Advertisement Management
Board Rules
cBB Chat
cBB Editor
cBB QuickMod
Forum Icons Extended
Medals System
Random avatars
Topic Author
VigLink
[**] Extensions .yml check

Versión de phpBB: 3.3
Versión de PHP: 7.4
Servidor: ProfesionalHosting
Si es una actualización desde otra versión: Actualizaciones consecutivas desde PhpBB 2.5 (aprox)



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1045
Registrado: 14 Ene 2017, 22:18
Género:

No se envian correos desde phpbb

#2

Mensaje por AbaddonOrmuz »

No te llega ni el mensaje de prueba? (PCA > General > Configuración de email > Enviar un correo electrónico de prueba)

Revisa el registro de errores de phpBB, esto es en el PCA > Mantenimiento > Registro de errores

Imagen

Deberías tener alguno relacionado con los correos electrónicos.

También podrías revisar en el registro de errores de tu proveedor de hosting, porque aunque sea la misma configuración que tenías antes, al tratarse de un servidor distinto al que tenías, podría tener algún puerto bloqueado o tener distintas especificaciones o configuraciones.

No indicas los ajustes de SMTP que actualmente estás usando, así que recomendaría verificar que el puerto sea el 587 y, si de esa forma no funciona ni el email de prueba, probar colocando tls:// justo antes de la dirección del servidor SMTP.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
chokie
Observador/a
Mensajes: 26
Registrado: 24 Ago 2014, 20:52

No se envian correos desde phpbb

#3

Mensaje por chokie »

No, ni el mensa de prueba.

En el log aparece este error:

Imagen

Segun me han dado a entender en el hosting, la web está redirigiendo a s41.profesionalhosting.com en vez de a google. Pero no tengo ni idea de como ha llegado a suceder eso. Supongo que la configuración de phpbb es localhost y por eso aparece s41.profesionalhosting.com. Pero ni idea de como cambiar eso.

En los ajustes de SMTP no uso cerficados, las tres opciones estan en no

Datos de Soporte

URL: https://www.fuerzasarmadas.eu
Estilo usuado: Base Prosilver
Extensiones instaladas:

Advertisement Management
Board Rules
cBB Chat
cBB Editor
cBB QuickMod
Forum Icons Extended
Medals System
Random avatars
Topic Author
VigLink
[**] Extensions .yml check

Versión de phpBB: 3.3
Versión de PHP: 7.4
Servidor: ProfesionalHosting
Si es una actualización desde otra versión: Actualizaciones consecutivas desde PhpBB 2.5 (aprox)



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1045
Registrado: 14 Ene 2017, 22:18
Género:

No se envian correos desde phpbb

#4

Mensaje por AbaddonOrmuz »

El servidor SMTP te está arrojando un error 535, que usualmente es por datos incorrectos con el nombre de usuario o contraseña, lo cual es normal considerando que las peticiones las esta procesando tu servidor y no el de G Suite.

Los registros MX (tienes 5 actualmente) parecen estar bien, y digo parece porque no he usado G Suite.

Por otro lado, la dirección IP del registro SPF (TXT) de tu dominio:

Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.

No coincide con la de tu servidor:

Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.

Tal vez quisieras revisar la documentación de G Suite para verificar que los registros DNS sean correctos, al igual que los datos SMTP, o podrías contactar con soporte técnico (de G Suite).

Enlaces de utilidad:

chokie escribió:
25 Jul 2020, 18:36

Segun me han dado a entender en el hosting, la web está redirigiendo a s41.profesionalhosting.com en vez de a google. Pero no tengo ni idea de como ha llegado a suceder eso.

Verifica que no estés usando el puerto 25.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
chokie
Observador/a
Mensajes: 26
Registrado: 24 Ago 2014, 20:52

No se envian correos desde phpbb

#5

Mensaje por chokie »

Los datos de GSuite son, en principio, correctos porque contacté con GSuite para obtenerlos y me guiaron para instalarlos. Contacté con Personalhosting, y de una manera un poco borde (no recomiendo el servicio al cliente de este hosting) me dijeron que el problema era de la web. Y se desentendieron.

Si te refieres al puerto SMTP, estoy usando el 587 y la dirección smtp.gmail.com que es lo que dice google. Como comentaba, en cuanto a configuración, es la misma que usaba anteriormente con la que sí que me funcionaba.

Al funcionar correctamente el correo electrónico desde fuera, envía y recibe correctamente. Intuyo que el problema está localizado en el propio phpbb

Datos de Soporte

URL: https://www.fuerzasarmadas.eu
Estilo usuado: Base Prosilver
Extensiones instaladas:

Advertisement Management
Board Rules
cBB Chat
cBB Editor
cBB QuickMod
Forum Icons Extended
Medals System
Random avatars
Topic Author
VigLink
[**] Extensions .yml check

Versión de phpBB: 3.3
Versión de PHP: 7.4
Servidor: ProfesionalHosting
Si es una actualización desde otra versión: Actualizaciones consecutivas desde PhpBB 2.5 (aprox)



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
picaron
Moderador
Mensajes: 440
Registrado: 04 Abr 2010, 20:01
Género:
Edad: 55

No se envian correos desde phpbb

#6

Mensaje por picaron »

AbaddonOrmuz escribió:
25 Jul 2020, 17:49

No indicas los ajustes de SMTP que actualmente estás usando, así que recomendaría verificar que el puerto sea el 587 y, si de esa forma no funciona ni el email de prueba, probar colocando tls:// justo antes de la dirección del servidor SMTP.

¿Has probado lo que ya te ha aconsejado @AbaddonOrmuz?

Es decir:

Código: Seleccionar todo

tls://smtp.gmail.com
puerto 587
Datos de Soporte

URL: http://www.ascensoristas.net
Versión phpBB: 3.3.1
EXT Instaladas:
Adsense & Ads
Advanced BBCode Box
Anti Adblock
Background Image in Text Area
Browser & OS in Viewtopic
cBB QuickMod
Contact Admin
External Links Open in New Window
Favorite icon
File Download
Google Analytics
Google Search & Site Verification
Image Upload
Imgur
Lightbox
mChat
Pages
Pay For Link
Paypal Donation
Post Links
Private Message Box Status Bars
QuickReply Reloaded
Scroll Page
Search Back
Simple mentions
Simple News Admin
Slideshow for Header
smilies scroll box
Store To Mega
Tabs BBCode
Thanks for posts
Ultimate Points Extension

Plantilla(s) usada(s):
prosilver
Black-Silver
Black-Silver-Slim
Black-Silver-Split
Carbon
CleanSilver
cubes
Elegance
Elegance Aqua
Elegance Green
Elegance LightBlue
Elegance SoftBlue
Elegance SoftGreen
Elegance SteelBlue
Flat Style
Flat Style Blue
Flat Style Gold
Flat Style Green
Flat Style Purple
Flat Style Red
Maxthon
ne-blackgreen
Orange_BBEs
prosilver Special Edition
Rock'n Roll
we_universal
X-Creamy

Servidor: Servidor Dedicado (No Administrado) Debian GNU/Linux 10 (buster) (x86_64) ovh.com
Actualización desde otra versión: 3.0.9
Conversión desde otro sistema de foros: No



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
chokie
Observador/a
Mensajes: 26
Registrado: 24 Ago 2014, 20:52

No se envian correos desde phpbb

#7

Mensaje por chokie »

picaron escribió:
26 Jul 2020, 11:21

¿Has probado lo que ya te ha aconsejado @AbaddonOrmuz?

Es decir:

Sí, no funciona. El error en ese caso es:

Error Email
» EMAIL/SMTP
/adm/index.php

No se puede conectar al servidor SMTP: 0 :

Errno 2: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
error:1408F10B:SSL routines:ssl3_get_record:wrong version number at [ROOT]/includes/functions_messenger.php line 1187<br />
Errno 2: stream_socket_client(): Failed to enable crypto at [ROOT]/includes/functions_messenger.php line 1187<br />
Errno 2: stream_socket_client(): unable to connect to tls://smtp.gmail.com:587 (Unknown error) at [ROOT]/includes/functions_messenger.php line 1187

Datos de Soporte

URL: https://www.fuerzasarmadas.eu
Estilo usuado: Base Prosilver
Extensiones instaladas:

Advertisement Management
Board Rules
cBB Chat
cBB Editor
cBB QuickMod
Forum Icons Extended
Medals System
Random avatars
Topic Author
VigLink
[**] Extensions .yml check

Versión de phpBB: 3.3
Versión de PHP: 7.4
Servidor: ProfesionalHosting
Si es una actualización desde otra versión: Actualizaciones consecutivas desde PhpBB 2.5 (aprox)



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
chokie
Observador/a
Mensajes: 26
Registrado: 24 Ago 2014, 20:52

No se envian correos desde phpbb

#8

Mensaje por chokie »

He contactado con el servicio técnico de GSuite y hemos borrado un TXT (SPF) extra que había en la configuración. Cuando se propaguen los datos, actualizo si esto ha servido como solución o no. Gracias de nuevo por vuestra ayuda ;)

Datos de Soporte

URL: https://www.fuerzasarmadas.eu
Estilo usuado: Base Prosilver
Extensiones instaladas:

Advertisement Management
Board Rules
cBB Chat
cBB Editor
cBB QuickMod
Forum Icons Extended
Medals System
Random avatars
Topic Author
VigLink
[**] Extensions .yml check

Versión de phpBB: 3.3
Versión de PHP: 7.4
Servidor: ProfesionalHosting
Si es una actualización desde otra versión: Actualizaciones consecutivas desde PhpBB 2.5 (aprox)



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
canidev
Moderador
Mensajes: 589
Registrado: 30 Jun 2011, 17:06
Género:
Edad: 33

No se envian correos desde phpbb

#9

Mensaje por canidev »

Borrar el registro SPF no suele ser buena idea.
¿Has revisado esta guía de tu hosting https://www.profesionalhosting.com/sopo ... suite.html ?
Ahí te especifica unos registros MX a poner, así como el registro SPF y también te dice que necesitas desactivar el servicio de correo interno del servidor.



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
chokie
Observador/a
Mensajes: 26
Registrado: 24 Ago 2014, 20:52

No se envian correos desde phpbb

#10

Mensaje por chokie »

canidev escribió:
26 Jul 2020, 19:56

Borrar el registro SPF no suele ser buena idea.

Es lo que me comentó el asistente técnico de google, compartiendo la pantalla vio que ese SPF ahí sobraba. No sabría decirte. Entre hoy y mañana que supongo que se habrá propagado, lo confirmaré.

Datos de Soporte

URL: https://www.fuerzasarmadas.eu
Estilo usuado: Base Prosilver
Extensiones instaladas:

Advertisement Management
Board Rules
cBB Chat
cBB Editor
cBB QuickMod
Forum Icons Extended
Medals System
Random avatars
Topic Author
VigLink
[**] Extensions .yml check

Versión de phpBB: 3.3
Versión de PHP: 7.4
Servidor: ProfesionalHosting
Si es una actualización desde otra versión: Actualizaciones consecutivas desde PhpBB 2.5 (aprox)



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1045
Registrado: 14 Ene 2017, 22:18
Género:

No se envian correos desde phpbb

#11

Mensaje por AbaddonOrmuz »

@chokie Tu problema se ha solucionado? podrías compartir la solución de ser el caso?

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.3”