Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Mail confirmación cuenta y recuperación password no funciona, resto siTema Solucionado

Foros de soporte phpBB 3.3


wonder
Asiduo/a
Mensajes: 100
Registrado: 14 Feb 2017, 00:09
Edad: 44

Mail confirmación cuenta y recuperación password no funciona, resto si

#1

Mensaje por wonder »

Hola.
Curioso lo que me sucede.
Tengo configurado, aparentemente bien, el tema de correo en el foro, cuando se registra un usuario recibo notificación (tengo mod para ello), cuando configuro, pulso enviar correo de prueba, y lo recibo, cuando contactan por enlace contacto, también recibo el correo pero....tengo configurado para que el usuario confirme su cuenta, tras registrarse, mediante mail, este mail, nunca llega.
Así mismo, si solicitas reestablecer contraseña, tampoco llega nunca.

Tras ver que se registraban usuarios y no se activaban cuentas, empecé a mirar y fue cuando lo ví.

Cree un usuario de prueba, y sucede eso, nunca llega el mail para activar cuenta, y si activo el usuario, posteriormente solicito reestablecer contraseña, tampoco llega nunca.

Verificada carpeta spam.

He buscado info, pero no he visto nada similar, o funciona o no funciona el correo, pero de este modo, no he encontrado nada....

Deduzco es tras la última actualización a 3.3.0 (mera deducción / suposición porque antes si funcionaba).

Gracias y saludos.



Datos de soporte actualizado a 21/03/2.020

Spoiler

URL: https://www.foroalejandria.com
Estilo(s) usuado(s): proSilver
Extensiones instaladas:
Advanced BBCode Box 3.2.2
Board Announcements 1.1.0
CloudFlare IP 1.1.2
External Link In New Window 1.0.1
Fixed footer navbar 1.0.3
Forum Legend 2.0.0
Forum name in Topic 1.0.1
Google Analytics 1.0.4
Header Banner 3.2.2
Modern quote 1.0.1
Notify Admin on Registration 1.0.1
Posting Buttons 1.0.1
Posting reset button 1.0.4
PostNumbers 1.1.2
Pretty Topic 1.0.1
Remove Subject from Replies 2.0.4
Simple mentions 1.0.3
smilies scroll box 1.0.3
Thanks for posts 2.0.6
Topic Author 1.0.2
Topic icons on index 1.0.1
Top Poster Of The Month 2.0.9
VigLink 1.0.5

Actualizado de otra versión? 302.9
Viene de conversión de otro foro? No
Versión de phpBB: 3.3.0
Servidor: De pago.


Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1085
Registrado: 14 Ene 2017, 22:18
Género:

Mail confirmación cuenta y recuperación password no funciona, resto si

#2

Mensaje por AbaddonOrmuz »

El problema ocurre con cualquier tipo de correo (Hotmail, Gmail, Yahoo, etc)?

Verifica si en el registro de errores de phpBB (Mantenimiento > Registro de errores) aparece algo que te pueda dar una pista, si hubo algún error al enviar un correo ahí aparecería. Revisar los errores del servidor también sería recomendable.

También revisa si el tamaño de paquetes es muy bajo, porque de ser así tal vez estén en la lista de espera. Aunque no estoy seguro si acciones como el restablecer la contraseña los envía a la lista de espera.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:


wonder
Asiduo/a
Mensajes: 100
Registrado: 14 Feb 2017, 00:09
Edad: 44

Mail confirmación cuenta y recuperación password no funciona, resto si

#3

Mensaje por wonder »

Pues creo has dado en el clavo (y yo no caí en ello....) pero tampoco se como solucionarlo...

Si estuviesen en la lista de espera, ya deberían haber salido, además, tanto los de recuperación contraseña como activación usuario, creo no pasan por la cola.

Pero en Mantenimiento - Registro de Errores, ahí si aparecen los errores del mail...
(Antes de seguir, probé y verifiqué era con cualquier dirección de mail, hotmail, gmail, la mia propia de mi dominio....).

Acabo de hacer un reenvio a un usuario que no esta activado, y acaba de generar este error:

Código: Seleccionar todo

Error Email
» EMAIL/SMTP
/foro/adm/index.php

No se puede obtener los códigos de respuesta del servidor de email.
Backtrace
Connecting to mail.midominio.com:465

Cabe indicar que, frente a este problema, hace unas horas desactivé la casilla de usar SMTP, la voy a seleccionar ahora, otro reenvio, y el error es distinto, es este concretamente:
Perdón, acabo de ver que es el mismo mensaje de error.
Curioso porque tengo configurado el puerto 587 y el error habla del puerto 465...
Y si le establezco el 465 entonces cuando pulso enviar correo de prueba se queda pensando y pensando y no lo envia nunca...

Aunque establezca el puerto 587 el foro lo intenta enviar por 465, si lo establezco a 465, no envia nada, se queda pensando y de ahí no pasa...
Posible "capado" del puerto 465 por parte del servidor? Pero aún así, yo le establezco el puerto 587 y el log de error indica se intenta conectar al 465...

Gracias por adelantado!!

Saludos!

Datos de soporte actualizado a 21/03/2.020

Spoiler

URL: https://www.foroalejandria.com
Estilo(s) usuado(s): proSilver
Extensiones instaladas:
Advanced BBCode Box 3.2.2
Board Announcements 1.1.0
CloudFlare IP 1.1.2
External Link In New Window 1.0.1
Fixed footer navbar 1.0.3
Forum Legend 2.0.0
Forum name in Topic 1.0.1
Google Analytics 1.0.4
Header Banner 3.2.2
Modern quote 1.0.1
Notify Admin on Registration 1.0.1
Posting Buttons 1.0.1
Posting reset button 1.0.4
PostNumbers 1.1.2
Pretty Topic 1.0.1
Remove Subject from Replies 2.0.4
Simple mentions 1.0.3
smilies scroll box 1.0.3
Thanks for posts 2.0.6
Topic Author 1.0.2
Topic icons on index 1.0.1
Top Poster Of The Month 2.0.9
VigLink 1.0.5

Actualizado de otra versión? 302.9
Viene de conversión de otro foro? No
Versión de phpBB: 3.3.0
Servidor: De pago.


Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1085
Registrado: 14 Ene 2017, 22:18
Género:

Mail confirmación cuenta y recuperación password no funciona, resto si

#4

Mensaje por AbaddonOrmuz »

Es probable que sea cosa del servidor SMTP, recuerdo haber visto un error similar con un cliente.

wonder escribió: 20 Mar 2020, 21:08

Curioso porque tengo configurado el puerto 587 y el error habla del puerto 465...

Checalo con tu proveedor de hosting, tal vez estén redirigiendo el tráfico de ese puerto.

wonder escribió: 20 Mar 2020, 21:08

Posible "capado" del puerto 465 por parte del servidor? Pero aún así, yo le establezco el puerto 587 y el log de error indica se intenta conectar al 465...

Revisa si el servidor tiene el puerto 2525 abierto, tal vez puedas usar ese en lugar del 587.

Alguna vez lo tuve que usar temporalmente pero con Mailgun, porque desde el puerto 587 no enviaba nada.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:


Avatar de Usuario
picaron
Moderador
Mensajes: 445
Registrado: 04 Abr 2010, 20:01
Género:
Edad: 55

Mail confirmación cuenta y recuperación password no funciona, resto si

#5

Mensaje por picaron »

mmmm.... ¿probaste a deshabilitar la extensión "CloudFlare IP 1.0.0"? :?:

Datos de Soporte

URL: http://www.ascensoristas.net
Versión phpBB: 3.3.1
EXT Instaladas:
Adsense & Ads
Advanced BBCode Box
Anti Adblock
Background Image in Text Area
Browser & OS in Viewtopic
cBB QuickMod
Contact Admin
External Links Open in New Window
Favorite icon
File Download
Google Analytics
Google Search & Site Verification
Image Upload
Imgur
Lightbox
mChat
Pages
Pay For Link
Paypal Donation
Post Links
Private Message Box Status Bars
QuickReply Reloaded
Scroll Page
Search Back
Simple mentions
Simple News Admin
Slideshow for Header
smilies scroll box
Store To Mega
Tabs BBCode
Thanks for posts
Ultimate Points Extension

Plantilla(s) usada(s):
prosilver
Black-Silver
Black-Silver-Slim
Black-Silver-Split
Carbon
CleanSilver
cubes
Elegance
Elegance Aqua
Elegance Green
Elegance LightBlue
Elegance SoftBlue
Elegance SoftGreen
Elegance SteelBlue
Flat Style
Flat Style Blue
Flat Style Gold
Flat Style Green
Flat Style Purple
Flat Style Red
Maxthon
ne-blackgreen
Orange_BBEs
prosilver Special Edition
Rock'n Roll
we_universal
X-Creamy

Servidor: Servidor Dedicado (No Administrado) Debian GNU/Linux 10 (buster) (x86_64) ovh.com
Actualización desde otra versión: 3.0.9
Conversión desde otro sistema de foros: No


wonder
Asiduo/a
Mensajes: 100
Registrado: 14 Feb 2017, 00:09
Edad: 44

Mail confirmación cuenta y recuperación password no funciona, resto si

#6

Mensaje por wonder »

Disculpad, quizás por las horas y el rato que llevo intentando...no soy capaz de ver para hacer un muli quote...lo haré "a mano" :)

AbaddonOrmuz escribió:

Es probable que sea cosa del servidor SMTP, recuerdo haber visto un error similar con un cliente.
...
Checalo con tu proveedor de hosting, tal vez estén redirigiendo el tráfico de ese puerto.
...
Revisa si el servidor tiene el puerto 2525 abierto, tal vez puedas usar ese en lugar del 587.

Alguna vez lo tuve que usar temporalmente pero con Mailgun, porque desde el puerto 587 no enviaba nada.

Voy a contactar con servidor, nunca me gustó pero...
Es que me es tan y tan extraño que el envio de prueba lo envia sin ningún problema, entiendo que si hubiese algún problema con el puerto, tampoco debiese enviar el correo de prueba, y este si, lo envia perfectamente.

Probé el 2525, mismo resultado...
Me voy quedando sin ideas... :)

picaron escribió:

mmmm.... ¿probaste a deshabilitar la extensión "CloudFlare IP 1.0.0"? :?:

La desactivé, mismo resultado......

Esto me recordó que debía actualizar las extensiones en mi firma, recién acabo de actualizarlas.

Gracias a ambos!

Datos de soporte actualizado a 21/03/2.020

Spoiler

URL: https://www.foroalejandria.com
Estilo(s) usuado(s): proSilver
Extensiones instaladas:
Advanced BBCode Box 3.2.2
Board Announcements 1.1.0
CloudFlare IP 1.1.2
External Link In New Window 1.0.1
Fixed footer navbar 1.0.3
Forum Legend 2.0.0
Forum name in Topic 1.0.1
Google Analytics 1.0.4
Header Banner 3.2.2
Modern quote 1.0.1
Notify Admin on Registration 1.0.1
Posting Buttons 1.0.1
Posting reset button 1.0.4
PostNumbers 1.1.2
Pretty Topic 1.0.1
Remove Subject from Replies 2.0.4
Simple mentions 1.0.3
smilies scroll box 1.0.3
Thanks for posts 2.0.6
Topic Author 1.0.2
Topic icons on index 1.0.1
Top Poster Of The Month 2.0.9
VigLink 1.0.5

Actualizado de otra versión? 302.9
Viene de conversión de otro foro? No
Versión de phpBB: 3.3.0
Servidor: De pago.


Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1085
Registrado: 14 Ene 2017, 22:18
Género:

Mail confirmación cuenta y recuperación password no funciona, resto si

#7

Mensaje por AbaddonOrmuz »

wonder escribió: 21 Mar 2020, 03:23

Disculpad, quizás por las horas y el rato que llevo intentando...no soy capaz de ver para hacer un muli quote...lo haré "a mano" :)

Selecciona el texto, y da clic en "Guardar cita" para ir acumulando eso, las citas :P en la parte inferior derecha tendrás un botón el listado que seleccionaste. Dando clic "Responder" sobrescribe la respuesta que hayas escrito.

Imagen

Ahora que @picaron comentó sobre CloudFlare no sé si esto te pueda ser útil:

Solución de problemas: Correo electrónico no se puede entregar cuando se usa Cloudflare

wonder escribió: 21 Mar 2020, 03:23

Me voy quedando sin ideas... :)

+1

Firewall? :nolose:

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:


wonder
Asiduo/a
Mensajes: 100
Registrado: 14 Feb 2017, 00:09
Edad: 44

Mail confirmación cuenta y recuperación password no funciona, resto si

#8

Mensaje por wonder »

AbaddonOrmuz escribió: 21 Mar 2020, 04:38

Selecciona el texto, y da clic en "Guardar cita" para ir acumulando eso, las citas :P en la parte inferior derecha tendrás un botón el listado que seleccionaste. Dando clic "Responder" sobrescribe la respuesta que hayas escrito.

Gracias!

AbaddonOrmuz escribió: 21 Mar 2020, 04:38

Ahora que @picaron comentó sobre CloudFlare no sé si esto te pueda ser útil:

Solución de problemas: Correo electrónico no se puede entregar cuando se usa Cloudflare

Lo pensé, pero cloudflare solo lo tengo para el registro A, osea, el dominio www. para el tema correo lo tengo desabilitado.

AbaddonOrmuz escribió: 21 Mar 2020, 04:38

+1

Firewall? :nolose:

Ni idea, no tengo acceso completo al server, es de pago, pero compartido y no es muy allá...ya me he puesto en contacto con ellos, a ver si me dan una respuesta.

Pero lo raro de todo esto es que, si estuviese "capado" el puerto o redireccionado, no enviaría ningún mail, en cambio, los de prueba, si los envia, los mails notificándome nuevo usuario registrado (tengo extensión para ello) también los recibo, son solo los de activación de cuenta (y recordar cuenta-password).
Unos si y otros no?

Eso es lo más raro para mi....

No se que sistema usa phpbb3 para el tema correos, pero deduzco que todos van del mismo modo....

Quizás algo se me quedó mal actualizado?

Ya no se me ocurre nada...

Datos de soporte actualizado a 21/03/2.020

Spoiler

URL: https://www.foroalejandria.com
Estilo(s) usuado(s): proSilver
Extensiones instaladas:
Advanced BBCode Box 3.2.2
Board Announcements 1.1.0
CloudFlare IP 1.1.2
External Link In New Window 1.0.1
Fixed footer navbar 1.0.3
Forum Legend 2.0.0
Forum name in Topic 1.0.1
Google Analytics 1.0.4
Header Banner 3.2.2
Modern quote 1.0.1
Notify Admin on Registration 1.0.1
Posting Buttons 1.0.1
Posting reset button 1.0.4
PostNumbers 1.1.2
Pretty Topic 1.0.1
Remove Subject from Replies 2.0.4
Simple mentions 1.0.3
smilies scroll box 1.0.3
Thanks for posts 2.0.6
Topic Author 1.0.2
Topic icons on index 1.0.1
Top Poster Of The Month 2.0.9
VigLink 1.0.5

Actualizado de otra versión? 302.9
Viene de conversión de otro foro? No
Versión de phpBB: 3.3.0
Servidor: De pago.


wonder
Asiduo/a
Mensajes: 100
Registrado: 14 Feb 2017, 00:09
Edad: 44

Mail confirmación cuenta y recuperación password no funciona, resto si

#9

Mensaje por wonder »

Bueno, finalmente problema solventado.
Tras pruebas, vi que no era problema de phpbb, me dió por enviar un mail desde una cuenta del dominio, no se enviaba (sin error), desde el propio webmail de cpanel, no error, pero tampoco llegaba...
Indicado todo ello al hosting, les envié copias de los mails returned (los que pasados 24/48 horas te indica no fue posible su entrega), hoy dictaminaron la migración de mi cuenta a otro servidor, y asunto solventado.
Cosa extraña, no había visto cosa igual en un server...pero bueno, quedó resuelto.

Aprovecho este hilo, aunque quizás fuese mejor abrir otro, tanto en el nuevo servidor, como en un VPS que tengo, al cuál le cree una cuenta e hice una instalación de 0, observo que, configurando la parte mail con el puerto 465 (el de SSL) no se envian, cuando pulso en enviar mail de prueba, se queda un rato largo y finalmente no lo envia.
Si solo me pasase en este, que es un shared, diría que tiene algo el server, pero en el VPS que tengo, al que le tengo acceso total y tengo otro foro (en otra plataforma) y este otro si envia por puerto 465...pienso que quizás si sea eso cosa de phpbb3 3.3.0.
Alguno lo tiene por puerto 465 y le funciona? Porque entonces si sería extraño, como comento, en el shared...podría pensar que eso, server, pero en el VPS no, ya que es un auto administrado por mi mismo y no tengo problema con otra plataforma de foro configurado por puerto 465.
Phpbb solo me funciona por puerto 587.

Saludos!

Datos de soporte actualizado a 21/03/2.020

Spoiler

URL: https://www.foroalejandria.com
Estilo(s) usuado(s): proSilver
Extensiones instaladas:
Advanced BBCode Box 3.2.2
Board Announcements 1.1.0
CloudFlare IP 1.1.2
External Link In New Window 1.0.1
Fixed footer navbar 1.0.3
Forum Legend 2.0.0
Forum name in Topic 1.0.1
Google Analytics 1.0.4
Header Banner 3.2.2
Modern quote 1.0.1
Notify Admin on Registration 1.0.1
Posting Buttons 1.0.1
Posting reset button 1.0.4
PostNumbers 1.1.2
Pretty Topic 1.0.1
Remove Subject from Replies 2.0.4
Simple mentions 1.0.3
smilies scroll box 1.0.3
Thanks for posts 2.0.6
Topic Author 1.0.2
Topic icons on index 1.0.1
Top Poster Of The Month 2.0.9
VigLink 1.0.5

Actualizado de otra versión? 302.9
Viene de conversión de otro foro? No
Versión de phpBB: 3.3.0
Servidor: De pago.


Avatar de Usuario
picaron
Moderador
Mensajes: 445
Registrado: 04 Abr 2010, 20:01
Género:
Edad: 55

Mail confirmación cuenta y recuperación password no funciona, resto si  Tema Solucionado

#10

Mensaje por picaron »

Hola @wonder, me alegro de que se haya resuelto tu problema.
Coincidirás conmigo en que en esta Comunidad nos dedicamos a dar soporte a phpBB y lo que estas consultando queda totalmente fuera de nuestro cometido.
Resumiendo tu caso, se trata de una configuración errónea a nivel del servidor y a esta situación no podemos dar soporte desde aquí, por lo que damos el tema por solucionado.

Nota: Podría ser hasta una configuración errónea del firewall del propio servidor.

Saludos.

Datos de Soporte

URL: http://www.ascensoristas.net
Versión phpBB: 3.3.1
EXT Instaladas:
Adsense & Ads
Advanced BBCode Box
Anti Adblock
Background Image in Text Area
Browser & OS in Viewtopic
cBB QuickMod
Contact Admin
External Links Open in New Window
Favorite icon
File Download
Google Analytics
Google Search & Site Verification
Image Upload
Imgur
Lightbox
mChat
Pages
Pay For Link
Paypal Donation
Post Links
Private Message Box Status Bars
QuickReply Reloaded
Scroll Page
Search Back
Simple mentions
Simple News Admin
Slideshow for Header
smilies scroll box
Store To Mega
Tabs BBCode
Thanks for posts
Ultimate Points Extension

Plantilla(s) usada(s):
prosilver
Black-Silver
Black-Silver-Slim
Black-Silver-Split
Carbon
CleanSilver
cubes
Elegance
Elegance Aqua
Elegance Green
Elegance LightBlue
Elegance SoftBlue
Elegance SoftGreen
Elegance SteelBlue
Flat Style
Flat Style Blue
Flat Style Gold
Flat Style Green
Flat Style Purple
Flat Style Red
Maxthon
ne-blackgreen
Orange_BBEs
prosilver Special Edition
Rock'n Roll
we_universal
X-Creamy

Servidor: Servidor Dedicado (No Administrado) Debian GNU/Linux 10 (buster) (x86_64) ovh.com
Actualización desde otra versión: 3.0.9
Conversión desde otro sistema de foros: No


  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.3”