Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Volver a empezar!

Foros de soporte phpBB 3.2


Avatar de Usuario
Todtuga
Elite
Mensajes: 1000
Registrado: 27 Oct 2008, 01:02
Género:
Edad: 59

Volver a empezar!

#1

Mensaje por Todtuga »

Buenas noches amigos! :hai: quería comentarles que decidí comenzar todo de nuevo. Algunos ya sabrán que mi foro actual esta estancado en la versión 3.2.0-dev y a estas altura del partido, di por perdido cualquier tipo de actualización a las nuevas versiones.
Así que aquí estoy para comentarles la idea "Titánica" que decidí emprender a partir de este momento. Momento en el que acabo de instalar desde "0" la última versión de phpbb3.2.5 full español, pero,...pero en un "servidor Local". Para ello el software que instale es;
- Wampserver 3.1.4 x64 (todo un tema para instalarlo correctamente)
- PHP versiones: 7.2.10 - 7.1.22 - 7.0.32 y 5.6.38, siendo la 7.1.22 la que utilicé para la instalación del phpbb3.2.5.
- Apache 2.4.35 (win64)
- PhpMyAdmin versión 4.8.4

La instalación de todos estos componentes fue exitosa, sin ningún inconveniente ni DEBUG alguno.
Asi que, vo y a comenzar a armar nuevamente el foro en mi PC, ir migrando de a poco temas y contenidos del foro que esta Online en este momento, e ir probando la manera de poder Migrar por lo menos toda la información y datos de mi usuario personal del foro anterior. Si logro hacerlo con éxito y consigo hacerlo de manera rápida? podré transferir todo el contenido de este ultimo al nuevo foro con al ultima versión phpbb3.2.5
Este tema lo voy a tener actualizado a medida que realice las tareas mencionadas, y acepto toda clase de críticas, consejos o orientación al respecto. Muchas gracias a todos como siempre.
Feliz Año 2019 para todos. :rock: :rock:


Datos de soporte
Spoiler
URL: http://www.citroentuc.com.ar
Versión phpBB: 3.2.0-dev
Plantilla(s) usada(s): Prosilver
Servidor: Linux - Pago
Actualización desde otra versión: si desde la 3.0.12
Conversión desde otro sistema de foros: no
El infinito es escaso a nuestra existencia.
Extensiones o MODs Instalados:Activity Stats 1.2.3-DEV, Advanced BBCode Box 3.1.4., Announcements on index 1.0.1., Annual Stars 1.0.0., Board Announcements 1.0.6., Board Rules 1.0.4., Category Background Image 1.0.1, Fade header 1.1.5. , Google AdSense 1.0.0., Google Analytics 1.0.2., Google Translator 1.0.0., Lightbox 1.0.5., National Flags 2.1.3., Paypal Donation 1.0.3., PM Welcome 1.0.1., Poster IP in Viewtopic 1.0.2., Red title for new topic and new reply 1.0.2., Right Side Random Image 3.1.0., Site logo 1.0.0-b4., Thanks for posts 2.0.2., Upload Extensions 3.1.2., Youtube Videos Gallery 1.0.3.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1045
Registrado: 14 Ene 2017, 22:18
Género:

Re: Volver a empezar!

#2

Mensaje por AbaddonOrmuz »

Yo te recomendaría que leyeras hacerca de cómo usar la terminal/consola en Windows, para poder ejecutar PHP desde Wampserver, no soy usuario de Windows así que no te sabría dar comandos exactos. Aquí hay información (en inglés) de cómo usar PHP en Windows usando XAMPP:

https://stackoverflow.com/questions/107 ... on-windows

Esto lo comento porque actualizar desde la terminal es tan simple como ejecutar un comando, y en mi experiencia haciendolo desde la consola te evitas problemas de tiempos de espera agotados, que si mal no recuerdo ese era el motivo por el cuál no podías actualizar.

Código: Seleccionar todo

cd /ruta_de_tu_foro
php bin/phpbbcli.php db:migrate --safe-mode
Y tras la actualización, opcionalmente:

Código: Seleccionar todo

php bin/phpbbcli.php reparser:reparse --safe-mode
Otra opción sería, y no me lo tomes a mal, que pagaras a alguien con experiencia (y no es auto promoción) para que lo actualizara por tí.

Si realmente deseas hacerlo por tu cuenta, lo que es bueno, te recomendaría que tengas mucha paciencia y ganas de aprender, para que no te des por vencido tan facilmente 8-) porque lo que intentas hacer no lo haría yo, son demasiadas cosas que pueden salir mal, especialmente los índices y llaves primarias de la base de datos, crearías un monstruo que sería aún más dificil de saber en donde esta el fallo en caso de tenerlos.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
Todtuga
Elite
Mensajes: 1000
Registrado: 27 Oct 2008, 01:02
Género:
Edad: 59

Re: Volver a empezar!

#3

Mensaje por Todtuga »

Gracias por tus sugerencias AbaddonOrmuz. Pero te comento que en un momento (no recuerdo cuando fue) solicite ayuda de alguien que supiera, y que vería la manera de pagar. Pero nunca se presentó nadie. Obviamente no tengo por que tomarlo a mal, y menos pretender que me hagan un trabajo de esta naturaleza gratuitamente. Si alguien me dice cuanto es el precio por solucionarme el problema que tengo en el foro actual Online, buscaría la manera de juntar el dinero y pagarlo. Por supuesto que siempre y cuando este dentro de mi presupuesto. Pero hasta la fecha nadie!
Datos de soporte
Spoiler
URL: http://www.citroentuc.com.ar
Versión phpBB: 3.2.0-dev
Plantilla(s) usada(s): Prosilver
Servidor: Linux - Pago
Actualización desde otra versión: si desde la 3.0.12
Conversión desde otro sistema de foros: no
El infinito es escaso a nuestra existencia.
Extensiones o MODs Instalados:Activity Stats 1.2.3-DEV, Advanced BBCode Box 3.1.4., Announcements on index 1.0.1., Annual Stars 1.0.0., Board Announcements 1.0.6., Board Rules 1.0.4., Category Background Image 1.0.1, Fade header 1.1.5. , Google AdSense 1.0.0., Google Analytics 1.0.2., Google Translator 1.0.0., Lightbox 1.0.5., National Flags 2.1.3., Paypal Donation 1.0.3., PM Welcome 1.0.1., Poster IP in Viewtopic 1.0.2., Red title for new topic and new reply 1.0.2., Right Side Random Image 3.1.0., Site logo 1.0.0-b4., Thanks for posts 2.0.2., Upload Extensions 3.1.2., Youtube Videos Gallery 1.0.3.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1045
Registrado: 14 Ene 2017, 22:18
Género:

Re: Volver a empezar!

#4

Mensaje por AbaddonOrmuz »

Yo podria hacer el trabajo, si estas interesado por privado podriamos ponernos deacuerdo ya que tengo unos dias libres

Te animo a que lo intentes almenos un par de veces en local con la línea de comandos, aquí se te podria ayudar teniendo información detallada de los errores que se te vayan presentando.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Volver a “🔎 Foros de Soporte 3.2”