Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Problemas al Habilitar o Deshabilitar una extension :C

Foros de soporte phpBB 3.2


Avatar de Usuario
Jihenjl
Observador/a
Mensajes: 9
Registrado: 26 Mar 2018, 01:39
Género:

Problemas al Habilitar o Deshabilitar una extension :C

#1

Mensaje por Jihenjl »

Buenos días a todos, espero que estén bien :)
Acudo a ustedes por el siguiente motivo.
Ayer tuve muchos problemas con el cache de mi foro, por alguna razón tenia que dar permisos de lectura a la extensión "IMAGE UPLOAD", con esto pude solucionar el problema que a simple vista era el único error que me generaba. Al entrar a la opción "Administrar Extensiones" no puedo deshabilitar o activar alguna extension. Lo raro de todo esto es que si me sale un mensaje diciendo que la operación está realizada correctamente, pero no es así, al regresar al índex de "Administrar Extensiones" me doy con la sorpresa que no ha efectuado dicha operación.

En el tema de agregar extensiones desde la raíz del servidor no hay ningún problema, por que me sale que hay una extension nueva por habilitar en "Administrar Extensiones"... y ya saben lo que pasa :cry:

Les dejo algunas capturas del problema.
1hb.jpg
2hb.jpg
3hb.jpg
Muchas gracias a todos por leer este mensaje :clap:

Datos de Soporte - Inicio

URL: (Localhost / lo tengo instalado en un NAS)
Estilo(s) usuado(s): (prosilver)
MODs/Extensiones instaladas: (Advanced BBCode Box - Collapsible Forum Categories - Header Banner - Image Upload - Pages - phpBB 3.2 Post Love - Precise Similar Topics - Prime note bbcode - Recent Topics - Topic Preview - Who Visited This Topic. )
Versión de phpBB: 3.2.1
Tu conocimiento: Principiante
Servidor: (NAS / QNAP)

Datos de Soporte - Fin

Especifica lo mejor posible el problema, copiando y pegando el error de tu sitio aquí (eliminando este texto claro está...)



Avatar de Usuario
ThE KuKa
Administrador
Mensajes: 9617
Registrado: 04 Ene 2004, 19:27
Género:
Edad: 46

Re: Problemas al Habilitar o Deshabilitar una extension :C

#2

Mensaje por ThE KuKa »

Hola,

¿Puedes habilitar el modo Debug en tu foro, a ver si aparece algún error?
Aquí se explica como habilitar el modo Debug en ambas versiones...
http://www.phpbb-es.com/foro/viewtopic. ... 57&t=39836

Saludos.

📌 Raul [ThE KuKa] en phpBB 📌
✅ Jr. Extension Validator - Jr. Styles Validator - Style Customisations - Translator - International Support Team
✅

Si te gustan mis estilos, traducciones, etc. y quieres mostrar algo de aprecio, no dudes en hacer una donación Imagen
:flag_es: phpBB España - En línea desde 2003 :heart:



Avatar de Usuario
Jihenjl
Observador/a
Mensajes: 9
Registrado: 26 Mar 2018, 01:39
Género:

Re: Problemas al Habilitar o Deshabilitar una extension :C

#3

Mensaje por Jihenjl »

Muchas gracias por tu tiempo
Realize el tutorial indicado y me salió estos errores


[phpBB Debug] PHP Notice: in file [ROOT]/ext/paybas/recenttopics/core/recenttopics.php on line 731: Trying to get property of non-object
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4517: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3268)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4517: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3268)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4517: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3268)

(O.O) (O.O) ¿Ahora qué debo hacer?

He deshabilitado la opción tema recientes desde EXTENSIONES, y ya no me aparece los errores en la página principal. Pero igual no me deja utilizar Administrador de Extensiones adecuadamente (O.O)

Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1085
Registrado: 14 Ene 2017, 22:18
Género:

Re: Problemas al Habilitar o Deshabilitar una extension :C

#4

Mensaje por AbaddonOrmuz »

Por lo que he visto, la propiedad num_rows no esta declarada en ninguna parte, probablemente hayas encontrado un bug. Sería mejor que lo reportaras al autor de la extensión.

Puedes intentar solucionar ese error remplazando el contenido de la líne 731:

Código: Seleccionar todo

$start = min($result->num_rows - 1 , $start);
Con lo siguiente:

Código: Seleccionar todo

$start = min(count($result) - 1 , $start);
Me estoy basando en lo que veo en la última versión disponible, no lo he probado, pero por lo que hace esa línea, lo anterior debería funcionar.

https://github.com/Sajaki/RecentTopics/ ... s.php#L731

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:


Avatar de Usuario
Jihenjl
Observador/a
Mensajes: 9
Registrado: 26 Mar 2018, 01:39
Género:

Re: Problemas al Habilitar o Deshabilitar una extension :C

#5

Mensaje por Jihenjl »

Muchas gracias por responder.
El problema persiste con respecto a la habilitación o deshabilitación de extensiones. En la página principal ya no me sale ningún error .

Lo que he hecho es migrar todo mi foro a una nueva url de mi Nas y así se soluciono el problema. Gracias por la ayuda :rock:

  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.2”