Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Ahora no se ven los PDF y antes no tenía problemas

Foros de soporte phpBB 3.2


Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Ahora no se ven los PDF y antes no tenía problemas

#1

Mensaje por J_Sparrow »

Creo que estas Navidades me va a tocar la lotería, estoy convencido, porque mas desgraciado no puedo ser :angry: , algo bueno me tendrá que pasar y creo que será eso.
Sigo repasando el Foro y corrigiendo cosas y algunas importantes no funcionan. A ver, la actualización fue un desastre, pero al final logré recuperar el control y la información. Creo que algunos problemas vienen derivados por el cambio de versión, pero otros no entiendo por que. Antes se veían los adjuntos y con la misma configuración en la nueva versión, los usuarios no los ven. Antes se veían los PDF a través de un BBCode que descargue en su día de la página oficial de phpBB en inglés https://www.phpbb.com/community/viewtop ... &t=2241886. Lo usé por activa y por pasiva sin problemas en la versión 3.1 y ahora me fijo que no funciona en la 3.2
No todo va a ser del cambio de versión, ya que después de unas horas intentando solucionar este problema y otro y de tener no se cuantas pestañas abiertas en el navegador, no he logrado hacerlo funcionar. Ya no sabía que hacer y me he percatado de un detalle importante, creo.
En la versión 3.1 tenía un aviso siempre en la pestaña de mi Foro, diciéndome que no era un sitio seguro (como pasa en este Foro). Para eliminar ese error, me dijeron que había que activar un certificado SSL, cretificado que no todos los servidores tienen gratuito y que a mi particularmente me costaba mucho dinero, dinero que ni tenía, ni estaba dispuesto a pagar. Cuando tuve el problema con la base de datos y al en mi cuenta del servidor para ver si podía conseguir una copia de la Base de Datos, vi que tenía una oferta o que me daban la posibilidad de activar el certificado SSL gratis. No me lo pensé y lo activé, ahora mi foro tiene el prefijo https
Pues bien, después de darle mil vueltas a lo del pdf, se me ha ocurrido quitar la "s" de la dirección del mensaje y vaya, se ve el pdf.
He visto en el ACP que hay una opción en "Configuración de cookies", para activar la "Cookie segura:", donde dice:
Si su servidor emplea SSL, habilite esta opción, si no, déjelo deshabilitado. Habilitar esto sin usar SSL provocará errores en el servidor.
¿Tengo que marcar Habilitado?, ¿me solucionará el problema de ver los pdfs?, ¿tendré problemas con el resto de cosas?, desconozco este tema y antes de hacer nada quiero vuestras inestimables opiniones, no sea que meta la pata hasta el fondo.
Igual el BBCode no funciona correctamente en la versión 3.2, no se, ya me estoy volviendo loco :rofl: :rofl:


Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Re: Ahora no se ven los PDF y antes no tenía problemas

#2

Mensaje por J_Sparrow »

Bueno, lo dejo por hoy, no encuentro el problema y en 5 horas me levanto.

Por cierto, me conformo con encontrar un BBCode, una extensión o lo que sea para poder ver los pdf en mi Foro. Si, ya he dicho que antes los veía, pero creo que el certificado SSL me esta jugando una mala pasada, porque es quitar la s de la dirección y se ven. ¿Por que será?.

Se me escapa de mis conocimientos.
Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1045
Registrado: 14 Ene 2017, 22:18
Género:

Re: Ahora no se ven los PDF y antes no tenía problemas

#3

Mensaje por AbaddonOrmuz »

No sé bien como funciona ese BBCode, pero si carga los PDF de un sitio externo en HTTP siendo tu dominio HTTPS, es muy probable que la conexión haya sido bloqueada por contener contenido mixto (mixed content), esto es que un servidor seguro sirve contenido inseguro.

Los navegadores como Firefox o Chrome, bloquean conexiones inseguras para evitar ataques. Checa tu consola web, porque si no es eso, las causas pueden ser muy variadas.

Como referencia checa estos enlaces (en ingles), insluso si no usas Firefox explica a grandes rasgos el tema.

https://support.mozilla.org/en-US/kb/mi ... ng-firefox
https://developer.mozilla.org/en-US/doc ... ed_content

Edito: Para solucionarlo, bastaría con cargar el contenido externo desde https://, sólo si es por contenido mixto.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1025
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Re: Ahora no se ven los PDF y antes no tenía problemas

#4

Mensaje por J_Sparrow »

Hola @AbaddonOrmuz , primeramente agradecerte tu tiempo y ayuda, no sabes lo mucho que te lo agradezco.
Llevo unos días en modo "prueba", ya que creo que he encontrado la solución, salvo que la cosa falle o me indiquéis lo contrario. Yo soy un auténtico ignorante en este tema en concreto, php y todo lo relacionado con ello. Ya lo he dicho muchas veces y lo vuelvo a repetir porque me siento orgulloso de decirlo: lo que se lo he aprendido principalmente de este Foro, al que le debo mucho y nunca podré devolverle la ayuda prestada.
Yo utilizo este BBCode:

Código: Seleccionar todo

[pdfview]{URL}[/pdfview]
Reemplazo HTML

Código: Seleccionar todo

<iframe src="http://docs.google.com/gview?url={URL}&embedded=true" style="width:600px; height:500px;" frameborder="0"></iframe>
Bueno, lo utilizaba, porque al no funcionar y después de muchas pruebas, se me ocurrió cambiar el enlace y añadirle al http, la "s" que también tengo ahora en mi Foro. Fue cambiarlo y empezar a verse los pdf. ¿Es la solución?, pues después de unos días y en vista que no ha vuelto a dejarse de ver los pdf, parece que es la solución.
¿Tus enlaces?, como te he dicho muchas gracias, aunque los leo y si te soy sincero, me suena un poco achino. No sabría donde tocar o que hay que hacer, así que si no me sugieres lo contrario, lo dejo como esta, con la "s" y me dedico a otras cosas, que dudas y preguntas no me faltan.

Gracias de nuevo a todos.
Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1045
Registrado: 14 Ene 2017, 22:18
Género:

Re: Ahora no se ven los PDF y antes no tenía problemas

#5

Mensaje por AbaddonOrmuz »

Sip, esa es lasolución 8-)

Es correcto el cambio y además me parece necesario ya que como comenté anteriormente, algunos navegadores bloquean las conexiones inseguras (en tu caso el visor de PDFs) por seguridad. Inclusive si en un futuro desinstalas tu certificado SSL y vuelve tu foro a tener una URL insegura (HTTP), el BBCode deberá seguir funcionando correctamente.

Otra opción es permitir que el navegador elija el protocolo omitiendo http: o https:, aunque personalmente no me agrada esta forma, es poco expresivo.

Código: Seleccionar todo

<iframe src="//docs.google.com/gview?url={URL}&embedded=true" style="width:600px; height:500px;" frameborder="0"></iframe>

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje
  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.2”