Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

(SOLUCIONADO) Falta menu de AOS who visited a topic 1.0.2.2 en ACPTema Solucionado

Foros donde podréis dejar vuestras dudas sobre phpBB 3.0.x
Cerrado
N_Javier
Observador/a
Mensajes: 27
Registrado: 05 Jul 2015, 04:48

(SOLUCIONADO) Falta menu de AOS who visited a topic 1.0.2.2 en ACP

#1

Mensaje por N_Javier » 30 Dic 2015, 06:18

Datos de soporte
URL: (http://infacover.uphero.com/)
Plantilla(s) usuada(s): (World of Warcraft: Alliance 3.0.13)
MODs instalados: (Thanks for posts, Ultimate SEO URL y Simple.Hide.BBcode.MOD_0.3.0)
Versión de phpBB: (phpbb 3.0.11)
Servidor: (gratis http://www.000webhost.com/)
Si es una actualización desde otra versión: (Ninguna)
Si es una conversión desde otro tipo de Foro: (Ninguna)

Aqui tengo instalado el MOD: http://infagamesfull.uphero.com/index.p ... fa9ba6707c
Hola a todos nuevamente,

Bueno, como siempre, acudo a usds hasta que veo que no voy a conseguir nada, bueno, mi problema es el siguiente:

Acabo de instalar AOS who visited a topic 1.0.2.2. (que por cierto, no se porque me sale que es 1.0.2.1) porque me llamo mucho la atencion, pero despues de instalarlo (que se hizo de manera exitosa sin arrojar ningun error) y entrar al ACP, me he dado cuenta que no me ha creado nada en el mismo, se supone que me creara un pequeño menu en:
ACP ---> General ---> Configuracion de mensaje

Y no me ha creado nada, ya lo desinstale e instale nuevamente y fue lo mismo, no se que podria ser, lo que si se me crea es una opcion en los permisos, y alli solo puedo decidir si alguien puede ver o no las visitas al dicho post, espero me puedan ayudar, gracias de antemano.

PD. Los datos no los puse ya que los tengo como firma, si aun asi debo de ponerlos, por favor me lo hacen saber y los pongo de inmediato, lo que si dejo al inicio es el lugar donde tengo el MOD, les recuerdo que yo siempre pruebo las cosas en un foro de prueba que tengo, pero en mi firma esta el oficial :D

Edito: Decidi poner los datos pese a lo que dije para no tener inconvenientes
Última edición por N_Javier el 07 Feb 2016, 02:44, editado 1 vez en total.


Datos de soporte
URL: (http://infacover.uphero.com/)
Plantilla(s) usuada(s): (World of Warcraft: Alliance 3.0.13)
MODs instalados: (Thanks for posts, Ultimate SEO URL, Simple.Hide.BBcode.MOD_0.3.0, Board3 Porta 2.0.2)
Versión de phpBB: (phpbb 3.0.11)
Servidor: (gratis http://www.000webhost.com/)
Si es una actualización desde otra versión: (Ninguna)
Si es una conversión desde otro tipo de Foro: (Ninguna)


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

N_Javier
Observador/a
Mensajes: 27
Registrado: 05 Jul 2015, 04:48

Re: Falta menu de AOS who visited a topic 1.0.2.2 en ACP

#2

Mensaje por N_Javier » 03 Ene 2016, 21:31

Bueno, despues de insistir tanto he llegado con la solucion al problema, ahora ya me aparece el menu en el ACP, ahora tengo una duda mas, hay alguna manera de que pueda hacer que ese MOD me registre tambien el numero de visitas de invitados que llegan? seria un solo grupo y que se defina como "invitados" y asi podeer saber cuantas visitas tiene el post por parte de los que no estan registrados, gracias de antemano :D
Datos de soporte
URL: (http://infacover.uphero.com/)
Plantilla(s) usuada(s): (World of Warcraft: Alliance 3.0.13)
MODs instalados: (Thanks for posts, Ultimate SEO URL, Simple.Hide.BBcode.MOD_0.3.0, Board3 Porta 2.0.2)
Versión de phpBB: (phpbb 3.0.11)
Servidor: (gratis http://www.000webhost.com/)
Si es una actualización desde otra versión: (Ninguna)
Si es una conversión desde otro tipo de Foro: (Ninguna)


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
towen
Moderador
Mensajes: 489
Registrado: 27 Dic 2011, 05:17
Nombre real: Pedro Almirall
Ubicación: Cuba
Género:
Edad: 24

Re: Falta menu de AOS who visited a topic 1.0.2.2 en ACP  Tema Solucionado

#3

Mensaje por towen » 04 Feb 2016, 03:21

Creo que lo que buscas es esto.

Abre el archivo includes/who_visited_a_topic.php

Buscar:

Código: Seleccionar todo

if ($config['topic_views_enabled'] && $user->data['is_registered'] && isset($user->data['session_page']) && !$user->data['is_bot'] && (strpos($user->data['session_page'], '&t=' . $topic_id) === false || isset($user->data['session_created']))) {
Reemplazar por:

Código: Seleccionar todo

if ($config['topic_views_enabled'] /* && $user->data['is_registered'] */ && isset($user->data['session_page']) && !$user->data['is_bot'] && (strpos($user->data['session_page'], '&t=' . $topic_id) === false || isset($user->data['session_created']))) {
Buscar:

Código: Seleccionar todo

// Verify some permissions
Agregar Antes:

Código: Seleccionar todo

	if ($userid == ANONYMOUS) {
		$username = '';
	}
	
Comenzando otra vez...
pedroall21@gmail.com


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

N_Javier
Observador/a
Mensajes: 27
Registrado: 05 Jul 2015, 04:48

Re: Falta menu de AOS who visited a topic 1.0.2.2 en ACP

#4

Mensaje por N_Javier » 06 Feb 2016, 04:37

Kazekage escribió:
Mostrar
Creo que lo que buscas es esto.

Abre el archivo includes/who_visited_a_topic.php

Buscar:

Código: Seleccionar todo

if ($config['topic_views_enabled'] && $user->data['is_registered'] && isset($user->data['session_page']) && !$user->data['is_bot'] && (strpos($user->data['session_page'], '&t=' . $topic_id) === false || isset($user->data['session_created']))) {
Reemplazar por:

Código: Seleccionar todo

if ($config['topic_views_enabled'] /* && $user->data['is_registered'] */ && isset($user->data['session_page']) && !$user->data['is_bot'] && (strpos($user->data['session_page'], '&t=' . $topic_id) === false || isset($user->data['session_created']))) {
Buscar:

Código: Seleccionar todo

// Verify some permissions
Agregar Antes:

Código: Seleccionar todo

	if ($userid == ANONYMOUS) {
		$username = '';
	}
	
y WUALA!!! Por arte de magia aparecio el grupo :rock:

Kazekage, eres un mago, pense que nadie me ayudaria en esto, pero apareciste con la mano salvadora :clap: en verdad te agradezco de todo corazon, estare agradecido eternamente contigo, ya pueden cerra el tema, SOLUCIONADO :cafe:
Datos de soporte
URL: (http://infacover.uphero.com/)
Plantilla(s) usuada(s): (World of Warcraft: Alliance 3.0.13)
MODs instalados: (Thanks for posts, Ultimate SEO URL, Simple.Hide.BBcode.MOD_0.3.0, Board3 Porta 2.0.2)
Versión de phpBB: (phpbb 3.0.11)
Servidor: (gratis http://www.000webhost.com/)
Si es una actualización desde otra versión: (Ninguna)
Si es una conversión desde otro tipo de Foro: (Ninguna)


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado

Volver a “Foros de Soporte 3.0.x”