Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

error SQL sin tocar nada

Foros donde podréis dejar vuestras dudas sobre phpBB 3.0.x
Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

error SQL sin tocar nada

#1

Mensaje por Enock »

Hola.

Pues de repente, hoy al identificarme en el foro me tira este error SQL:
Error General
SQL ERROR [ mysqli ]

'data01_onlinewii_unityweb_es.p.image_filename' isn't in GROUP BY [1055]

SQL

SELECT p.*, u.user_id, u.username, u.user_colour, r.rate_image_id, AVG(r.rate_point) AS rating, COUNT(DISTINCT c.comment_id) AS comments FROM phpbb3_gallery_images AS p LEFT JOIN phpbb3_users AS u ON p.image_user_id = u.user_id LEFT JOIN phpbb3_gallery_albums AS ct ON p.image_album_id = ct.album_id LEFT JOIN phpbb3_gallery_rates AS r ON p.image_id = r.rate_image_id LEFT JOIN phpbb3_gallery_comments AS c ON p.image_id = c.comment_image_id WHERE ((image_album_id IN ('29', '28', '25', '1', '22'))) AND ( p.image_status = 1) GROUP BY p.image_id ORDER BY RAND() LIMIT 4

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 758
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/portal/block/center_gallery_random_picsonly_body.php
LINE: 105
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/portal/includes/index_blocks.php
LINE: 59
CALL: include_once('[ROOT]/portal/block/center_gallery_random_picsonly_body.php')

FILE: [ROOT]/index.php
LINE: 547
CALL: include_once('[ROOT]/portal/includes/index_blocks.php')
No se ha tocado nada y de repente tira este error. ¿Alguien podría iluminarme?

Un saludo, gracias.


URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
ThE KuKa
Administrador
Mensajes: 9339
Registrado: 04 Ene 2004, 19:27
Nombre real: Raúl
Ubicación: Terrassa
Género:
Edad: 45
Contactar:

Re: error SQL sin tocar nada

#2

Mensaje por ThE KuKa »

¿Has probado de analizar, reparar y optimizar las tablas del foro?

📌 Raul [ThE KuKa] en phpBB 📌
✅ Jr. Extension Validator - Jr. Styles Validator - Style Customisations - Translator - International Support Team
✅

Si te gustan mis estilos, traducciones, etc. y quieres mostrar algo de aprecio, no dudes en hacer una donación Imagen
:flag_es: phpBB España - En línea desde 2003 :heart:




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

Re: error SQL sin tocar nada

#3

Mensaje por Enock »

ThE KuKa escribió:¿Has probado de analizar, reparar y optimizar las tablas del foro?
Si, pero sigue igual. :(


EDITO: me he dado cuenta de una cosa; cuando intento reparar la tabla "phpbb3_log", me tira el siguiente error:
Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /phpmyadmin/db_structure.php.

Reason: Error reading from remote server
Sin embargo, con el resto de tablas de la base de datos no da error alguno. :?:

EDITO 2: Bueno, el error solo sale en el índice, por lo que entrando por el portal www.onlinewii.es/foro/portal.php he podido loguearme y entrar en el PDA. Viendo que el error indicaba algo del "Gallery", he probado desactivando el bloque que tenía puesto del MOD Gallery, en el índice, y ya he podido acceder al índice. Pero.....

Navegando por el foro, si intento entrar a algún mensaje, me tira este error:
Error General
SQL ERROR [ mysqli ]

'data01_onlinewii_unityweb_es.f.forum_id' isn't in GROUP BY [1055]

SQL

SELECT f.*, t.*, u.user_id, u.username, u.user_colour FROM (phpbb3_topics t) LEFT JOIN phpbb3_users u ON (u.user_id = t.topic_poster) LEFT JOIN phpbb3_forums f ON (f.forum_id = t.forum_id) WHERE MATCH (t.topic_title) AGAINST ('Antes de nada....' IN BOOLEAN MODE) AND t.topic_status <> 2 AND t.topic_id <> 515 GROUP BY t.topic_id ORDER BY rand() LIMIT 5

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 758
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 224
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/includes/db/dbal.php
LINE: 170
CALL: dbal_mysqli->_sql_query_limit()

FILE: [ROOT]/viewtopic.php
LINE: 2814
CALL: dbal->sql_query_limit()
Gracias.
Última edición por Enock el 08 Mar 2013, 23:30, editado 1 vez en total.
URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Alorse
Ex Staff
Mensajes: 5144
Registrado: 22 Mar 2008, 02:14
Nombre real: Alfredo
Ubicación: Colombia
Género:
Edad: 32
Contactar:

Re: error SQL sin tocar nada

#4

Mensaje por Alorse »

Enock escribió:EDITO: me he dado cuenta de una cosa; cuando intento reparar la tabla "phpbb3_log", me tira el siguiente error:
Pide ayuda a tu servicio de host, ya que el problema al parecer viene desde allí.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

Re: error SQL sin tocar nada

#5

Mensaje por Enock »

Alorse escribió:
Enock escribió:EDITO: me he dado cuenta de una cosa; cuando intento reparar la tabla "phpbb3_log", me tira el siguiente error:
Pide ayuda a tu servicio de host, ya que el problema al parecer viene desde allí.

Gracias, ya he comentado ese error al hosting.

Por otra parte, el error de SQL que me sigue dando al intentar entrar en cualquier mensaje, ¿alguna idea?.

Un saludo, gracias.
URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Alorse
Ex Staff
Mensajes: 5144
Registrado: 22 Mar 2008, 02:14
Nombre real: Alfredo
Ubicación: Colombia
Género:
Edad: 32
Contactar:

Re: error SQL sin tocar nada

#6

Mensaje por Alorse »

Yo creo que todos los errores se deben a lo mismo, si no has tocado nada como lo dijiste, no deberían porque salir.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

Re: error SQL sin tocar nada

#7

Mensaje por Enock »

Ok, según el hosting, el problema es que, cito:
Hace 5 dias estamos utilizando la sistema de galera cluster en modo seguro, y eso significa que sql que son mal construidos ya no estan permitidos
Y en el "viewtopic.php" hay un código del MOD Similar Topics que está "mal construido", por eso tira el error.

Voy a mirar si tengo la última versión del MOD y actualizarlo si es necesario, para ver si se soluciona. De lo contrario, no se que hacer, ya que no se como dejar bien el código para que no tire error.
URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

Re: error SQL sin tocar nada

#8

Mensaje por Enock »

Hola.

Pues bien, he actualizado el MOD "Similar Topics" a la última versión que he encontrado, y sigue dando error.

He "comentado" en el archivo "viewtopic.php" el código de dicho MOD, que es el que hace la consulta que me comentó el hosting, el cual hace que salte error, y funciona sin problemas.

Aquí os dejo el código que he "comentado" en el archivo:

Código: Seleccionar todo

// Begin similar topics
$sql_array = array(
	'SELECT'	=> 'f.forum_id, f.forum_name, t.topic_id, t.topic_title, u.user_id, u.username, u.user_colour, t.topic_replies',

	'FROM'		=> array(
		TOPICS_TABLE	=> 't',
	),

	'LEFT_JOIN'	=> array(
		array(
			'FROM'	=>	array(USERS_TABLE	=> 'u'),
			'ON'	=> 'u.user_id = t.topic_poster'
	),
		array(
			'FROM'	=>	array(FORUMS_TABLE	=> 'f'),
			'ON'	=> 'f.forum_id = t.forum_id'
		),
	),

	'WHERE'		=> "MATCH (t.topic_title) AGAINST ('" . $db->sql_escape($topic_data['topic_title']) . "' ) >= 0.5
		AND t.topic_status <> " . ITEM_MOVED . '
		AND t.topic_id <> ' . (int) $topic_data['topic_id'],

	'GROUP_BY'	=> 't.topic_id',

	'ORDER_BY'	=> 't.topic_last_post_time DESC',
);
$sql = $db->sql_build_query('SELECT', $sql_array);
if ($result = $db->sql_query_limit($sql, 5))
{
	while($similar = $db->sql_fetchrow($result))
	{
		if ($auth->acl_get('f_read', $similar['forum_id']))
		{
			$similar_forum_url	= append_sid("{$phpbb_root_path}viewforum.$phpEx", "f=" . $similar['forum_id']);
			$similar_topic_url	= append_sid("{$phpbb_root_path}viewtopic.$phpEx", "f=" . $similar['forum_id'] . '&t=' . $similar['topic_id']);
			$similar_user		= get_username_string('full', $similar['user_id'], $similar['username'], $similar['user_colour'], $similar['username']);

			$template->assign_block_vars('similar', array(
				'TOPIC_TITLE'			=> $similar['topic_title'],
				'U_TOPIC'				=> $similar_topic_url,
				'REPLIES'				=> $similar['topic_replies'],
				'USER'					=> $similar_user,
				'U_FORUM'				=> $similar_forum_url,
				'FORUM'					=> $similar['forum_name'])
			);
		}
	}
}
// End Similar Topics
A ver si alguien que sepa sabe a que se debe.

Por otro lado, he encontrado este otro MOD https://www.phpbb.com/customise/db/mod/ ... topics_ii/ que hace lo mismo, a ver si este no da el error.

Un saludo, gracias.
Última edición por Enock el 11 Mar 2013, 11:07, editado 1 vez en total.
URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Alorse
Ex Staff
Mensajes: 5144
Registrado: 22 Mar 2008, 02:14
Nombre real: Alfredo
Ubicación: Colombia
Género:
Edad: 32
Contactar:

Re: error SQL sin tocar nada

#9

Mensaje por Alorse »

Para mi la consulta esta correctamente construida, la probé ejecutándola directamente en mysql y no mostró ningún error.
Prueba dos cosas:
  1. Ejecuta esta consulta directamente en la base de datos:

    Código: Seleccionar todo

    SELECT f.*, t.*, u.user_id, u.username, u.user_colour FROM (phpbb3_topics t) LEFT JOIN phpbb3_users u ON (u.user_id = t.topic_poster) LEFT JOIN phpbb3_forums f ON (f.forum_id = t.forum_id) WHERE MATCH (t.topic_title) AGAINST ('Antes de nada....' IN BOOLEAN MODE) AND t.topic_status <> 2 AND t.topic_id <> 515 GROUP BY t.topic_id ORDER BY rand() LIMIT 5
    Si se ejecuta sin errores, es porque esta bien construida.
  2. Prueba este MOD en localhost, ya sea en una copia de tu foro (ojala esta) o en un foro nuevo para ver si da errores, si se ejecuta correctamente, es problema de tu hosting y tendríamos que buscar la manera de cambiar la consulta sin el GROUP BY.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

Re: error SQL sin tocar nada

#10

Mensaje por Enock »

Gracias por probarlo.

Te comento que para probarlo bien debería estar tal y como lo tienen ellos ahora, que según cité arriba es:
Hace 5 dias estamos utilizando la sistema de galera cluster en modo seguro, y eso significa que sql que son mal construidos ya no estan permitidos
Falla la consulta desde que pusieron eso así. No se que es, y tampoco si está bien escrito ya que a veces se lian con las palabras españolas.

Un saludo, gracias.
URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Alorse
Ex Staff
Mensajes: 5144
Registrado: 22 Mar 2008, 02:14
Nombre real: Alfredo
Ubicación: Colombia
Género:
Edad: 32
Contactar:

Re: error SQL sin tocar nada

#11

Mensaje por Alorse »

Enock escribió:Te comento que para probarlo bien debería estar tal y como lo tienen ellos ahora, que según cité arriba es:
Pero lo probaste, hiciste el intento?
Si lo hiciste que error te muestra?


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

Re: error SQL sin tocar nada

#12

Mensaje por Enock »

Alorse escribió:
Enock escribió:Te comento que para probarlo bien debería estar tal y como lo tienen ellos ahora, que según cité arriba es:
Pero lo probaste, hiciste el intento?
Si lo hiciste que error te muestra?
No, no he podido probar aun. En cuanto pueda pruebo en local al ver si se poner el mysql tal y como me han dicho que lo tienen.
Lo que si probé fue des instalar el similar topics e instalar el que comento en post anterior, el " precise similar topics", y este no da errores.
Un saludo, gracias.
URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
javiexin
Miembro
Mensajes: 270
Registrado: 20 Dic 2010, 20:13
Nombre real: Javier

Re: error SQL sin tocar nada

#13

Mensaje por javiexin »

El error proviene del propio código de phpbb. Está documentado en este "bugtracker": http://tracker.phpbb.com/browse/PHPBB3- ... y-tabpanel

Parece que se corregirá en phpbb 3.0.12.

Mientrastanto, yo cambié el modo de búsqueda de Fulltext Native a Fulltext MySQL (creando el índice adecuado), y todo funciona.

Perdón por no haber respondido antes, pero no había visto la pregunta.

Saludos,
-javiexin
URL: http://www.exincastillos.es
Spoiler
Versión phpBB: phpBB3 (3.0.9)
MODs Instalados: Ver Lista de MODs instalados
Plantilla(s) usada(s): prosilver
Servidor: Linux de pago
Actualización desde otra versión: 3.0.8, 3.0.5, 2.x


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
Enock
Miembro
Mensajes: 444
Registrado: 15 Jul 2009, 14:57
Nombre real: Francisco
Ubicación: España
Edad: 41
Contactar:

Re: error SQL sin tocar nada

#14

Mensaje por Enock »

Gracias javiexin, no había caido en preguntarte a ti ya que usamos el mismo hosting e imagino que te pasó lo mismo.

De momento lo he cambiado ya que aunque arreglé uno de los errores, salía en otras partes como en los perfiles.

Un saludo.
URL: http://www.onlinewii.es/foro/index.php
Versión phpBB: phpBB3 (3.0.11)
MODs Instalados:
Spoiler
Portal XL5.0 Pre-mod 0.3 + MODs incluidos,
ajax chat,
respuesta rápida,
blog mod,
Gallery mod,
th23 autolinks,
Prime Subject Check 1.4.19,
TinyPic Plugin,
Manage Attachments ACP,
New Topic Button,
Post Models 1.0.3,
Subforum Display Options 1.0.1,
Anti Double Post 2.0.4,
Automatic Spammer Detection 1.0.0 B5,
Topic Solved 1.4.4,
Download MOD 6.4.2,
Ultimate Points 1.0.7,
UPS Easy Shop 0.7.0,
Annual Stars 1.0.1a,
Duplicate Users IP 1.0.0,
Mods Database 1.0.7,
Prime Ban to Group 1.0.2,
Special and Normal Ranks Images 1.2.0,
MOD Browse and IOS icons,
[ABD] IP Search 2.3.3,
Advanced Paypal Donation MOD,
Forum Title Colour 1.0.3,
Invite a Friend 0.6.2,
automod 1.0.0
Auto BackUp 1.0.2...
Plantilla(s) usada(s): Prosilver y Artodia: Mobile & SEO
Servidor: Linux pago
Actualización desde otra versión: phpbb3 3.0.7 PL1
Conversión desde otro sistema de foros:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
invi
Ex Staff
Mensajes: 2550
Registrado: 14 Ene 2006, 16:25
Ubicación: Asturias
Género:
Edad: 33

Re: error SQL sin tocar nada

#15

Mensaje por invi »

Entonces en que queda esto? solucionado? no solucionado? a ver.. porque yo me he perdido :lol:
Existen dos tipos de individuos, los que saben y los que no.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado

Volver a “Foros de Soporte 3.0.x”