Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Error cuando actualizo a php 5.4Tema Solucionado

Foros donde podréis dejar vuestras dudas sobre phpBB 3.0.x
Avatar de Usuario
emil
Usuario/a
Mensajes: 84
Registrado: 06 Sep 2010, 14:33
Género:
Edad: 40

Error cuando actualizo a php 5.4

#1

Mensaje por emil »

He actualizado a php 5.4 y cuando veo los temas me sale una pantalla de error:

Fatal error: Call-time pass-by-reference has been removed in http://www.geekland.xunem.com/Foro/viewtopic.php on line 1138

he probado instalar un foro en limpio y no me sale ese error, luego intuyo que puede ser por la plantilla, pero no estoy seguro...

En fin, con la versión 5.2 de php no me ocurre esto. Me podrian ayudar? Gracias


Datos del foro
  • Nombre del foro: geekland
  • URL de tu web: https://notfake.000webhostapp.com/
  • Hosting donde esta alojada: 000webhost [Gratuito]
  • Sistema y version de foros: phpBB-3.2.3
  • Estilo utilizado: prosilver

Avatar de Usuario
angelismo
Administrador
Mensajes: 5705
Registrado: 20 May 2006, 02:42
Género:
Edad: 32

Re: Error cuando actualizo a php 5.4

#2

Mensaje por angelismo »

Te estas liando ,la versión de php ,es algo distinto a la versión de phpBB3 , y ademas eso lo puede actualizar tu host.

Antes de nada, lee las Normas de phpBB-Es y las Normas de Soporte.

Como corregir el copyright de phpbb3 - Si tu foro no tiene copyright ,lee la guia antes de pedir soporte.
No doy soporte por MP ni por MSN ,solo en los foros.


© angelismo- Webmaster de Webmastercreativo
© angelismo -Administrador de phpBB-es

Avatar de Usuario
emil
Usuario/a
Mensajes: 84
Registrado: 06 Sep 2010, 14:33
Género:
Edad: 40

Re: Error cuando actualizo a php 5.4

#3

Mensaje por emil »

Comorl ? No que va, se perfectamente diferenciar php de phpbb3.

En mi host se puede actualizar manualmente a php 5.2, 5.3 y 5.4.

El problema aparece cuando la versión no es 5.2 o sea en versiones 5.3 y 5.4

Y ese error que me sale tiene toda la pinta de salir por que algo se cambió en el código de php (no en versiones de phpbb3)

Lo de probar en un foro en limpio, era solo para descartar errores en phpbb3
Datos del foro
  • Nombre del foro: geekland
  • URL de tu web: https://notfake.000webhostapp.com/
  • Hosting donde esta alojada: 000webhost [Gratuito]
  • Sistema y version de foros: phpBB-3.2.3
  • Estilo utilizado: prosilver

Avatar de Usuario
ThE KuKa
Administrador
Mensajes: 9617
Registrado: 04 Ene 2004, 19:27
Género:
Edad: 46

Re: Error cuando actualizo a php 5.4

#4

Mensaje por ThE KuKa »

Del estilo dudo que sea, es probable que sea de alguno de los MODs, puedes copiar y pegar el archivo en cuestión en PasteBin de este foro, o adjuntarlo. :?:

Así podemos mirarlo, aunque ahora mismo acabo de visitar tu foro, y si leo los temas correctamente, si lo hace en un tema especifico, pon la URL del mismo por favor.

📌 Raul [ThE KuKa] en phpBB 📌
✅ Jr. Extension Validator - Jr. Styles Validator - Style Customisations - Translator - International Support Team
✅

Si te gustan mis estilos, traducciones, etc. y quieres mostrar algo de aprecio, no dudes en hacer una donación Imagen
:flag_es: phpBB España - En línea desde 2003 :heart:



Avatar de Usuario
emil
Usuario/a
Mensajes: 84
Registrado: 06 Sep 2010, 14:33
Género:
Edad: 40

Re: Error cuando actualizo a php 5.4  Tema Solucionado

#5

Mensaje por emil »

Ya lo solucioné.

Efectivamente, el error lo ocasiona un mod pero es debido a php.

En viewtopic.php

linea

Código: Seleccionar todo

easyDelete::add_rowset(&$rowset[$row['post_id']], $row);
reemplazar por

Código: Seleccionar todo

asyDelete::add_rowset($rowset[$row['post_id']], $row);
simplemente hay que quitar el aspersan

Pero otra cosa que provoca el mismo error es que si instalas phpbb3 3.0.11 con php 5.4.0

te sale el error

Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in includes\utf\utf_tools.php on line 1781

Abrir /includes/startup.php

linea

Código: Seleccionar todo

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
reemplazar por

Código: Seleccionar todo

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
Sin embargo si uso php 5.2 este error no sale ?!
Última edición por emil el 16 Ene 2013, 20:58, editado 3 veces en total.
Datos del foro
  • Nombre del foro: geekland
  • URL de tu web: https://notfake.000webhostapp.com/
  • Hosting donde esta alojada: 000webhost [Gratuito]
  • Sistema y version de foros: phpBB-3.2.3
  • Estilo utilizado: prosilver


Volver a “Foros de Soporte 3.0.x”