Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1Tema Solucionado

Soporte de MODs para phpBB 3.0.x
Dudas sobre AutoMOD aquí por favor.

0
No hay votos
 
Votos totales: 0

ummo
Observador/a
Mensajes: 4
Registrado: 18 Nov 2010, 22:04
Edad: 56

Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#1

Mensaje por ummo »

Aun a costa de repetir lo que se ha dicho ya muchas veces, quisiera agradecer al autor de este MOD su magnífico trabajo. Todavía no lo tengo instalado pero después de ver todas las mejoras que añade a los foros me he quedado impresionado y no veo el momento de verlo funcionar.

Bueno, pues resulta que acabo de instalar un foro que todavía no está activo y lo estoy puliendo antes de lanzarlo. Me acabo de poner a instalar el 'Advanced BBCode Box 3 (aka ABBC3)' Versión 3.0.8-pl1 y me he encontrado con la primera duda. A saber:

Estoy editando el primer fichero (adm/style/acp_users_signature.html) y en la cuarta modificación me encuentro la duda. En las instrucciones dice que busque la línea siguiente:

Código: Seleccionar todo

<dd style="margin-left: 90px;"><textarea name="signature"
Tras ella tengo que añadir id="signature" pero el problema es que esa línea no existe tal cual. Imagino que esa parte de código se habrá modificado en el cambio de versión de phpBB 3.0.7 PL1 a 3.0.8 y la línea se ha sustituido por esta:

Código: Seleccionar todo

<dd style="margin-{S_CONTENT_FLOW_BEGIN}: 90px;"><textarea name="signature"
Y ahora la pregunta: ¿Añado id="signature" sin miedo a que me pueda causar problemas? ¿Funcionará bien?

Acabo de ver otra cosa y me ha surgido una última duda (de momento):
Veo que hay que editar algunos ficheros de la plantilla "prosilver" pero yo uso "subsilver2". ¿Tengo que hacer esos cambios en mi plantilla o esos cambios son exclusivos para "prosilver"? ¿Los cambios son exactamente los mismos? Estoy instalando el MOD a mano y he visto una pregunta similar en el foro en la que se comenta que el AutoMOD los hace en ambas plantillas, pero me gustaría asegurarme y saber exactamente cómo lo he de hacer.

Muchas gracias por la ayuda y, de nuevo, muchas gracias por el MOD.


[hr]
URL: http://mabu.zobyhost.com
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Welcome PM on first Login (WPM)' Version 2.2.5, AutoMOD 1.0.0, Advanced BBCode Box 3 v3.0.8 pl1
Plantilla(s) usada(s): subsilver2
Servidor: http://www.zobyhost.com (Linux, gratuito)
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No

ummo
Observador/a
Mensajes: 4
Registrado: 18 Nov 2010, 22:04
Edad: 56

Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#2

Mensaje por ummo »

He estado modificando el fichero en modo local, para no tocar nada en el servidor y me he encontrado un nuevo cambio. La siguiente modificación del fichero adm/style/acp_users_signature.html, la quinta, tampoco es igual. En lugar de esta línea:

Código: Seleccionar todo

<dd style="margin-left: 90px; margin-top: 5px;">
me encuentro esta otra:

Código: Seleccionar todo

<dd style="margin-{S_CONTENT_FLOW_BEGIN}: 90px; margin-top: 5px;">
El código que tengo que agregar antes ¿puedo agregarlo igualmente sin miedo?

Imagino que cambios de estos encontraré varios a medida que vaya avanzando. Iré modificando los ficheros en modo local y los subiré una vez tenga la seguridad de que no habrá problemas.
Muchas gracias.
[hr]
URL: http://mabu.zobyhost.com
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Welcome PM on first Login (WPM)' Version 2.2.5, AutoMOD 1.0.0, Advanced BBCode Box 3 v3.0.8 pl1
Plantilla(s) usada(s): subsilver2
Servidor: http://www.zobyhost.com (Linux, gratuito)
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No

Avatar de Usuario
leviatan21
Ex Staff
Mensajes: 8279
Registrado: 26 Mar 2008, 20:06
Género:
Edad: 50

Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1  Tema Solucionado

#3

Mensaje por leviatan21 »

ummo escribió:Aun a costa de repetir lo que se ha dicho ya muchas veces, quisiera agradecer al autor de este MOD su magnífico trabajo.
Gracias :oops:

Desde el lanzamiento de phpbb v3.0.8 nosotros, los autores de este MOD hemos visto estas diferencias y ya hemos solicitado que se corrijan, pero aún no se libera esta nueva versión, por lo que nos vimos obligados a publicar el parche : phpBB 3.0.8 - READ BEFORE Installing ABBC 3.0.8-pl1 donde se corrigen esos problemas de lineas que han cambiado desde la versión anterior de phpbb.

Como tu mismo dices, AutoMOD hace la instalación muy fácil y es capaz de hacerlo en prosilver y subsilver al mismo tiempo y también brinda la posibilidad de hacerlo en otros estilos.
Pero si tu lo quieres hacer a mano, bien por ti, a mi entender, es la mejor manera de ir conociendo como funciona.

En cuanto a los estilos, yo siempre recomiendo instalar los MODs también en los otros estilos, nunca sabes si en un futuro decides cambiarlos.
Este MOD, sigue las normas de phpbb y en el instalador proncipal, se dan las instrucciones para el código general y el estilo prosilver, para instalarlo en el estilo Subsilver, se agrega un instalador aparte, y figura en el bloque Additional MODX files del instalador principal y aparece primero en el listado como Template: Changes for Subsilver2 based style

Si necesitas mas aclaraciones, sólo pregunta :ok:
Normas de phpBB España | Normas de Soporte
No doy soporte por privado : tenga en cuenta que su problema, también puede ser el problema de otro usuario.
Cualquier mensaje privado no solicitado será ignorado :twisted:

"Education is what remains after one has forgotten everything he learned in school" - Albert Einstein

Avatar de Usuario
Pretorix
Miembro
Mensajes: 234
Registrado: 16 May 2006, 17:34
Género:
Edad: 54

Re: Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#4

Mensaje por Pretorix »

Me parece Excelente y actualizado.
En breve lo probaré en aero.
Ojalá todo vaya bien.
Gracias.
DATOS DE SOPORTE:
Spoiler
Powered by phpBB 3.0.12 (actualizado de phpBB 3.0.10, actualizado de phpBB-3.09, phpBB-3.08, phpBB-3.07-PL1, phpBB-3.06 y actualizado sucesivamente de las versiones desde phpBB-3.02, y actualizado de phpBB-2.0.23 y actualizado sucesivamente de las versiones desde phpBB-0,19).
URL del foro
Estilos; Skyboot 1.0.3 y Prosilver 3.0.12
MODS instalados;
- Manage attachments ACP module for phpBB3 1.2.0
- cBB Blockgets v1.0.4
- Anti Double Posts 2.0.2
- NV_recent_topics_1_0_5
- Tapatalk Forums
- sortables_captcha_plugin_1_0_4
PLUGINS instalados;
- Cookie Law v1.0.0
-------------------------
Gracias a http://www.phpbb-es.com/foro

Avatar de Usuario
leviatan21
Ex Staff
Mensajes: 8279
Registrado: 26 Mar 2008, 20:06
Género:
Edad: 50

Re: Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#5

Mensaje por leviatan21 »

Pretorix escribió:En breve lo probaré en aero.
Ojalá todo vaya bien.
Espero que si, los estilos Aero suelen ser complicados, algunas veces responden al código de prosilver, pero en general se ajustan al estilo subsilver2
Normas de phpBB España | Normas de Soporte
No doy soporte por privado : tenga en cuenta que su problema, también puede ser el problema de otro usuario.
Cualquier mensaje privado no solicitado será ignorado :twisted:

"Education is what remains after one has forgotten everything he learned in school" - Albert Einstein

ummo
Observador/a
Mensajes: 4
Registrado: 18 Nov 2010, 22:04
Edad: 56

Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#6

Mensaje por ummo »

leviatan21 escribió:Como tu mismo dices, AutoMOD hace la instalación muy fácil y es capaz de hacerlo en prosilver y subsilver al mismo tiempo y también brinda la posibilidad de hacerlo en otros estilos.
Pero si tu lo quieres hacer a mano, bien por ti, a mi entender, es la mejor manera de ir conociendo como funciona.
Pues sí, siempre me ha gustado hacer las cosas a mano a pesar de no ser entendido en estas cosas, por eso que comentas de aprender. Pero en esta ocasión voy a dejarlo donde estoy y lo voy a hacer con el AutoMOD en cuanto lo instale. No es que me haya asustado, pero es que veo que hay mucho trabajo para instalar este MOD y si puedo hacerlo en poco tiempo mucho mejor. En el enlace que me has puesto veo que serán pocas las modificaciones que habré de hacer y así me ganaré un tiempo precioso.

En cuanto tenga listo el MOD ya avisaré. No he dicho nada hasta ahora porque mi servidor ha estado caído unas cuantas horas.

Muchas gracias.
[hr]
URL: http://mabu.zobyhost.com
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Welcome PM on first Login (WPM)' Version 2.2.5, AutoMOD 1.0.0, Advanced BBCode Box 3 v3.0.8 pl1
Plantilla(s) usada(s): subsilver2
Servidor: http://www.zobyhost.com (Linux, gratuito)
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No

ummo
Observador/a
Mensajes: 4
Registrado: 18 Nov 2010, 22:04
Edad: 56

Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#7

Mensaje por ummo »

Pues nada, al final lo he instalado con el AutoMOD y me ha asombrado la rapidez con que lo ha hecho. Siguiendo las instrucciones del enlace que me diste al principio he hecho las modificaciones que faltaban a mano y parece que funciona todo estupendamente. Tan solo echo en falta la posibilidad de centrar los vídeos, pues el botón de centrar texto no sirve, así que he tenido que habilitar el BBCode [center], aunque queda un poco cutre ese botón tan triste después de ver todos los iconos que se instalan con el MOD.

En fin, repito mis felicitaciones por tan currado y magnífico MOD.

Un saludo.
[hr]
URL: http://mabu.zobyhost.com
Versión phpBB: phpBB3 (3.0.8)
MODs Instalados: Welcome PM on first Login (WPM)' Version 2.2.5, AutoMOD 1.0.0, Advanced BBCode Box 3 v3.0.8 pl1
Plantilla(s) usada(s): subsilver2
Servidor: http://www.zobyhost.com (Linux, gratuito)
Actualización desde otra versión: No
Conversión desde otro sistema de foros: No

Avatar de Usuario
Pretorix
Miembro
Mensajes: 234
Registrado: 16 May 2006, 17:34
Género:
Edad: 54

Re: Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#8

Mensaje por Pretorix »

En el antiguo template, tenía el mod de mitch, pero al ser un template nuevo no veo necesidad de sesinstalar el de Mitch, sóloeliminar la carpeta de las imágnes, y reemplazar los BBcodes con los de este, no creo que haya conflicto
¿Estoy equivocado?

Y otra pregunta se pueden dejar algunos BBcodes sin mostrar en el BBC?

Gracias.
DATOS DE SOPORTE:
Spoiler
Powered by phpBB 3.0.12 (actualizado de phpBB 3.0.10, actualizado de phpBB-3.09, phpBB-3.08, phpBB-3.07-PL1, phpBB-3.06 y actualizado sucesivamente de las versiones desde phpBB-3.02, y actualizado de phpBB-2.0.23 y actualizado sucesivamente de las versiones desde phpBB-0,19).
URL del foro
Estilos; Skyboot 1.0.3 y Prosilver 3.0.12
MODS instalados;
- Manage attachments ACP module for phpBB3 1.2.0
- cBB Blockgets v1.0.4
- Anti Double Posts 2.0.2
- NV_recent_topics_1_0_5
- Tapatalk Forums
- sortables_captcha_plugin_1_0_4
PLUGINS instalados;
- Cookie Law v1.0.0
-------------------------
Gracias a http://www.phpbb-es.com/foro

Avatar de Usuario
leviatan21
Ex Staff
Mensajes: 8279
Registrado: 26 Mar 2008, 20:06
Género:
Edad: 50

Re: Dudas con Advanced BBCode Box 3 Versión 3.0.8-pl1

#9

Mensaje por leviatan21 »

Pretorix escribió:En el antiguo template, tenía el mod de mitch, pero al ser un template nuevo no veo necesidad de sesinstalar el de Mitch, sóloeliminar la carpeta de las imágnes, y reemplazar los BBcodes con los de este, no creo que haya conflicto
¿Estoy equivocado?
No lo se, no tengo idea que cambios hace el MOD de mitch :roll:
Pretorix escribió:Y otra pregunta se pueden dejar algunos BBcodes sin mostrar en el BBC?
Si se puede, el panel de control de los bbcodes del ABBC3, cada bbcode tiene 3 configuraciones : mensajes, privado y firmas, marcas o desmarcas a tu gusto :P
Normas de phpBB España | Normas de Soporte
No doy soporte por privado : tenga en cuenta que su problema, también puede ser el problema de otro usuario.
Cualquier mensaje privado no solicitado será ignorado :twisted:

"Education is what remains after one has forgotten everything he learned in school" - Albert Einstein


Volver a “Soporte de MODs”