Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

No se pueden ver los hilosTema Solucionado

Soporte de Extensiones para phpBB 3.3
💡 Como instalar una Extensión
Sandro77
Observador/a
Mensajes: 4
Registrado: 09 Nov 2020, 22:18

No se pueden ver los hilos

#1

Mensaje por Sandro77 »

Hola :)

He instalado la versión más reciente de phpBB, desde 0, y luego restaurado una copia de seguridad que hice antes de eliminar todo. El foro sale con los hilos que había antes, pero al entrar a cualquiera, aparece el mensaje:

Código: Seleccionar todo

Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "profilefields.type.googleplus". Did you mean one of these: "profilefields.type.bool", "profilefields.type.date", "profilefields.type.dropdown", "profilefields.type.text", "profilefields.type.url", "profilefields.type_collection"? in /customers/8/d/3/arefepedia.es/httpd.www/foro/vendor/symfony/dependency-injection/Container.php:348 Stack trace: #0 /customers/8/d/3/arefepedia.es/httpd.www/foro/phpbb/di/service_collection.php(57): Symfony\Component\DependencyInjection\Container->get('profilefields.t...') 
#1 /customers/8/d/3/arefepedia.es/httpd.www/foro/phpbb/profilefields/manager.php(452): phpbb\di\service_collection->offsetGet('profilefields.t...') 
#2 /customers/8/d/3/arefepedia.es/httpd.www/foro/viewtopic.php(1919): phpbb\profilefields\manager->generate_profile_fields_template_data(Array) 
#3 {main} thrown in /customers/8/d/3/arefepedia.es/httpd.www/foro/vendor/symfony/dependency-injection/Container.php on line 348

URL: arefepedia.es/foro/
Estilo(s) usuado(s): prosilver
Extensiones instaladas: viglink y adduser. También debería estar canidev/chat, pero está deshabilitado
Versión de phpBB: 3.3.2
Versión de PHP: 7.4.12
Versión de MySQL: MySQL(i) 10.3.25-MariaDB-1:10.3.25+mariabionic
Servidor: one.com, de pago
Si es una actualización desde otra versión: No
Si es una conversión desde otro tipo de Foro: No

Muchas gracias




Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1085
Registrado: 14 Ene 2017, 22:18
Género:

Re: No se pueden ver los hilos

#2

Mensaje por AbaddonOrmuz »

Bienvenido @Sandro77 :sunglasses:

Sandro77 escribió: 10 Nov 2020, 12:15

He instalado la versión más reciente de phpBB, desde 0, y luego restaurado una copia de seguridad que hice antes de eliminar todo.

¿Qué versión tenías anteriormente? El campo personalizado de Google+ fue eliminado en phpBB 3.3.1, y es el error que te marca porque dejaste tu foro en un estado inconsistente, con archivos de una versión superior pero con la base de datos con una versión inferior.

Si tu intención era actualizar, ese no es la forma correcta de hacerlo porque tendrás errores de éste tipo.

Puedes corregir ese error actualizando la base de datos, para ello sigue ésta guía: Actualizando phpBB 3.2.x (sirve para 3.3.x aunque diga que es para 3.2.x)

En el paso 3, puedes descargar en su lugar el paquete completo en español: phpBB Español

Tras actualizar, limpia la caché.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:


Sandro77
Observador/a
Mensajes: 4
Registrado: 09 Nov 2020, 22:18

Re: No se pueden ver los hilos

#3

Mensaje por Sandro77 »

Gracias :)

No recuerdo exactamente, antes estaba un amigo y hace poco me encargué de la administración, se instaló por primera vez en julio de 2015, y creo que no se ha actualizado desde entonces, será la 3.0 o la 3.1

Pues sí, iba a actualizar, pero no debí de hacerlo bien, así que hice una copia de seguridad (de los archivos no) y lo volví a instalar de 0, ya con la versión más reciente.

Lo haré, ya te cuento, ¡muchas gracias!


Sandro77
Observador/a
Mensajes: 4
Registrado: 09 Nov 2020, 22:18

Re: No se pueden ver los hilos

#4

Mensaje por Sandro77 »

Nada, sale que no se puede cargar la página, error 401, y no puedo acceder al ACP


Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 1085
Registrado: 14 Ene 2017, 22:18
Género:

Re: No se pueden ver los hilos

#5

Mensaje por AbaddonOrmuz »

@Sandro77 Veo que el foro, de tus datos de soporte, ya esta actualizado a 3.3.2 :sunglasses:

Podrías confirmar si ya se solucionó el problema?

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:


Sandro77
Observador/a
Mensajes: 4
Registrado: 09 Nov 2020, 22:18

Re: No se pueden ver los hilos  Tema Solucionado

#6

Mensaje por Sandro77 »

Sí, muchas gracias, ya funciona bien, asombrosamente, no entraba desde el jueves, y ahora está todo en su sitio (O.O)

Lo único es que no puedo entrar en el Panel de Administración, al loguearme pone lo siguiente:

The password reset functionality has been disabled. If you need help accessing your account, please contact the Board Administrator

y claro, le doy a Board Administrator y no funciona (la primera vez que probé salía el mensaje de que no existía)

Pero muchísimas gracias, me habéis ayudado un montón :D


  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “Soporte de Extensiones 3.3”