Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Error general al intentar registrarse en el foro en la versión 3.3.0

Foros de soporte phpBB 3.3


Fernando_N
Observador/a
Mensajes: 21
Registrado: 02 Oct 2013, 23:35

Error general al intentar registrarse en el foro en la versión 3.3.0

#1

Mensaje por Fernando_N »

URL: http://nowsat.info/foro
Estilo usuado: Prosilver
Extensiones instaladas: Boards announcements y Board rules
Versión de phpBB: 3.3.0
Versión de PHP: 7.4.1
Servidor: pago
Si es una actualización desde otra versión: 3.2.8 a 3.3.0

Después de llevar algunas semanas con la versión 3.3.0, que finalmente puse, resulta que varias personas me han comentado que no se pueden registrar en el foro. Y así es, da este error:

SQL ERROR [ mysqli ]

Unknown column 'user_email_hash' in 'field list' [1054]

Ocurrió un error SQL mientras recuperaba esta página. Por favor, contacta con La Administración del sitio si el problema persiste.

Parece un error con la base de datos que no tengo ni idea de cómo solucionar. Estaré muy agradecido a quien me pueda echar una mano, ya que si tengo que hacer un backup al 5 de Enero, más o menos a cuando se actualizó, volverían todos los mensajes a ese día, un desastre total. Y ni siquiera sé si así se solucionaría.
Gracias.

Última edición por Fernando_N el 26 Ene 2020, 00:10, editado 1 vez en total.




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 962
Registrado: 14 Ene 2017, 22:18
Género:

Error general al intentar registarte en el foro en la versión 3.3.0

#2

Mensaje por AbaddonOrmuz »

Te indica desde qué archivos proviene el error? Revisa el registro de errores de tu servidor.

Hasta donde tengo entendido la columna user_email_hash fue eliminada de la tabla de usuarios.

Intenta limpiando la caché, puede que esa columna sólo este incluida en una consulta SQL desde la caché.

Algunas de mis extensiones:
Imagen Imgur | :chart_with_upwards_trend: SEO Metadata | Imagen Markdown | :lock: Auto-lock Topics | :mermaid: Mermaid Diagrams
:trophy: Checa todas mi extensiones aprobadas :trophy:

:penguin: Usuario de Arch Linux :penguin:



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Fernando_N
Observador/a
Mensajes: 21
Registrado: 02 Oct 2013, 23:35

Error general al intentar registarte en el foro en la versión 3.3.0

#3

Mensaje por Fernando_N »

Ante todo, muchas gracias por la rapidísima respuesta AbaddonOrmuz.
Hablé con el servidor y me dijeron que de la parte del servidor está todo correcto. Aunque si me dijeron que daba un error, que no se completaba la operación del registro por un error que me indicaron y pegaron para que viera dónde estaba (ni idea). Cambiamos la versión de PHP, pero no solucionó nada.
Ya probé a limpiar la caché y nada de nada.
He tratado de reinstalar la versión 3.3.0 y cuando instalo la carpeta "Install", para que actualice la base de datos, el navegador no llama a la carpeta y me tira una página en blanco. Y no tengo claro que una instalación limpia de la 3.3.0 me solucione el problema, ya que parece ser de la base de datos.
El historial es el siguiente: pongo la versión 3.3.0, venía de la 3.2.8. Veo que da problemas y vuelvo a la 3.2.8. Pero cuál es mi sorpresa que el PCA me indica que sigo en la 3.3.0. Lo dejó así y ahora me encuentro con el problema del registro de usuarios.
No me he encontrado con nada igual en los casi 10 años que llevo con el phpbb, pues no sé ya qué hacer para solucionarlo.
¿Alguna idea?
Muchas gracias de nuevo a este magnifico soporte de Phpbb España.



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Fernando_N
Observador/a
Mensajes: 21
Registrado: 02 Oct 2013, 23:35

Error general al intentar registrarse en el foro en la versión 3.3.0

#4

Mensaje por Fernando_N »

Me respondo yo mismo. Sospeché que el PCA, a pesar de indicar que mi versión era la 3.3.0, realmente tenía aún la 3.2.8, que fue de hecho para lo que hice el backup, recuperar esa versión. Y así lo hice, pero estas semanas en el PCA indicaba que tenía la 3.3.0
Así que ante mis sospechas, he reinstalado la 3.3.0 y, si bien el actualizador me ha dado un error diciendo que algunos archivos no se podían actualizar, me ha dado la opción de actualizar la base de datos, solo. Esta acción ha resuelto el problema, ya funciona lo de actualizar.
Pero tengo el problema inicial que tenía con la versión 3.3.0, que el logo del foro ha desaparecido, como y comenté en otro tema.
No sé si puedo tratar el tema aquí o abro nuevo post.
La otra vez ya probé a subir la imagen del logo en esta versión y no había manera de que cambiara. ¿Alguna idea?
Gracias.



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
J_Sparrow
Moderador
Mensajes: 1011
Registrado: 30 Oct 2009, 00:20
Género:
Edad: 59

Error general al intentar registrarse en el foro en la versión 3.3.0

#5

Mensaje por J_Sparrow »

Fernando_N escribió:
26 Ene 2020, 08:36

No sé si puedo tratar el tema aquí o abro nuevo post.

Abre otro tema, así no mezclamos las cosas.
Aunque ahora que lo pienso, juraría que lo del Logo en la 3.3.0 ya ha preguntado alguien, o ya lo ha comentado alguien.

Contenido Oculto
Este foro requiere que este registrado e identificado para ver el contenido oculto.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Fernando_N
Observador/a
Mensajes: 21
Registrado: 02 Oct 2013, 23:35

Error general al intentar registrarse en el foro en la versión 3.3.0

#6

Mensaje por Fernando_N »

Si, lo comenté yo mismo en este mismo foro de soporte 3.3.0, en el mensaje de "Fallos al instalar la versión 3.3.0"



Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

  • Temas similares
    Respuestas
    Vistas
    Último mensaje

Volver a “🔎 Foros de Soporte 3.3”