Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Could not connect to the database, see error message below.

Foros de soporte phpBB 3.1.x
Cerrado
PAC
Observador/a
Mensajes: 3
Registrado: 05 Feb 2018, 19:59
Nombre real: Pablo

Could not connect to the database, see error message below.

Mensaje por PAC » 05 Feb 2018, 20:56

Buenas tardes! soy nuevo en el foro y también en la instalación del mismo, vi que hay gente reporto el mismo problema pero las soluciones allí aplicadas no me dieron resultado, ojala me puedan orientar para que mi primer experiencia no sea la última :D

No estoy logrando que conecte con la base de datos, ya probé poner la ip, el dominio, la ip, localhost, localhost/sqlserver que es lo que según el proveedor del hosting sería el acceso:

Internal Server: localhost\SQLEXPRESS


Imagen




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
canidev
Moderador
Mensajes: 531
Registrado: 30 Jun 2011, 17:06
Nombre real: Iván
Género:
Contactar:

Re: Could not connect to the database, see error message below.

Mensaje por canidev » 05 Feb 2018, 21:50

Hola

Lo primero, para darte soporte necesitamos los "Datos de soporte". Aunque aún no tengas URL, datos como el servidor que utilizas pueden servir para ayudarte.
http://www.phpbb-es.com/foro/viewtopic.php?f=4&t=10547

Por otra parte aprovecho para preguntarte. ¿Estás instalando phpBB 3.1 o 3.2?


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

PAC
Observador/a
Mensajes: 3
Registrado: 05 Feb 2018, 19:59
Nombre real: Pablo

Re: Could not connect to the database, see error message below.

Mensaje por PAC » 06 Feb 2018, 15:07

Buen día, gracias por responder y perdón, arranque mal ya...

URL: pendiente
Estilo(s) usuado(s): estandar
Extensiones instaladas: ninguna
Versión de phpBB: 3.0
Servidor: pago, sin posibilidad de actualizar el php por eso la versión 3.0 de phpbb

Por otro lado también veo que ya no se da soporte al 3.0, por lo que definitivamente estoy al horno, ya que al ser un servidor compartido no me permiten actualizar la versión de php.

Si alguno se le ocurre una alternativa realmente le agradezco el tiempo, y nuevamente disculpen.

Saludos

Imagen


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
canidev
Moderador
Mensajes: 531
Registrado: 30 Jun 2011, 17:06
Nombre real: Iván
Género:
Contactar:

Re: Could not connect to the database, see error message below.

Mensaje por canidev » 06 Feb 2018, 16:45

Dos preguntas:
¿que versión de php usa tu hosting?
En la captura veo que tienes soporte para usar mysqli ¿porque utilizas mssql y no mysqli?

Ya no damos soporte a phpBB 3.0 en este foro pero me extraña que un hosting de pago use una versión de php tan obsoleta como para que no puedas instalar una versión más reciente.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

PAC
Observador/a
Mensajes: 3
Registrado: 05 Feb 2018, 19:59
Nombre real: Pablo

Re: Could not connect to the database, see error message below.

Mensaje por PAC » 06 Feb 2018, 18:28

La versión de php es 5.2.14, me comentan que al no ser un server dedicado no pueden actualizar porque podría afectar a otros usuarios. La solución sería migrar todos los sitios (tengo una cuenta de resseller) a un server que ya tiene php actualizado y sería algo no muy simple.

Respecto a la base de datos ahi si realice la elección yo al contratar el plan, ya que uno de los sitios que almaceno usa esa, puedo preguntar si me permiten cambiar a mysql solo el dominio donde tengo el foro y ver si así se resuelve el tema de la conexión.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
angelismo
Administrador
Mensajes: 5707
Registrado: 20 May 2006, 02:42
Nombre real: Angel
Ubicación: España
Género:
Contactar:

Re: Could not connect to the database, see error message below.

Mensaje por angelismo » 06 Feb 2018, 20:07

Si hosting no permite el cambio de versión php, lo mejor que puedes hacer es buscar otro hosting

Antes de nada, lee las Normas de phpBB-Es y las Normas de Soporte.

Como corregir el copyright de phpbb3 - Si tu foro no tiene copyright ,lee la guia antes de pedir soporte.
No doy soporte por MP ni por MSN ,solo en los foros.


© angelismo- Webmaster de Webmastercreativo
© angelismo -Administrador de phpBB-es


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 567
Registrado: 14 Ene 2017, 22:18
Nombre real: Alfredo
Ubicación: /dev/null
Género:
Contactar:

Re: Could not connect to the database, see error message below.

Mensaje por AbaddonOrmuz » 06 Feb 2018, 21:21

En hostings compartidos modernos es posible seleccionar la versión de PHP desde cPanel entre una lista especificada por el propio proveedor, así que como comenta @angelismo, deberías considerar cambiar de proveedor.

Sería mejor que solucionaras primero el asunto de la versión de PHP, te dará problemas en un futuro con aplicaciones web modernas, la versión que comentas ya ni siquiera recibe actualizaciones de seguridad.
Algunas de mis extensiones: [ Imgur | Metadatos SEO | Markdown ]
Checa todas mi extensiones
Usuario de Arch Linux


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado