imagenComo sabéis el soporte para phpBB 3.0 ha sido cerrado, solo se dará soporte para las actualizaciones a phpBB 3.1 o phpBB 3.2

Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro.

Gracias.

La Administración de phpBB España.
Foros donde podréis dejar vuestras dudas sobre phpBB 3.2.x
  • Avatar de Usuario
  • Avatar de Usuario
Por wonder
#237514
Hello.
Recientemente, instale phpbb3, he ido a activar la opción de Aviso de Cookie, por los temas legales, pero ya vi en descripción que, requiere de las extensiones habilitadas.
Por ello, aunque lo active y guarde cambios, al regresar a la pagina de config, sale no habilitado.

Me fui a extensiones a buscar, no vi ninguna...(o no supe buscar bien)... :sweat:

He encontrado alguna cosa para versiones inferiores, y una que pensé podria servir, ya no existe el archivo.

Gracias de antemano y un saludo!
Avatar de Usuario
Por uruguayito
#237515
Esta extensión hace lo que quieres y es para tu versión 3.2 https://www.phpbb.com/community/viewtop ... lit=cookie
Avatar de Usuario
Por andares
#237517
@wonder el aviso de cookies implementado por defecto en 3.2 funciona bien y sin problemas.

Probablemente no te vuelve a salir por que aunque le des a "Borrar todas las cookies del Sitio", esa cookie en concreto no la elimina, tendrás que hacerlo manualmente desde la configuración de tu navegador, veras que entre las cookies guardadas con la dirección de tu foro hay una con el nombre de "cookieconsent_status", borrala y seguidamente recarga la pagina de tu foro, el aviso vuelve a salir.
wonder le gusta esto
Por wonder
#237518
Hola andares,
El caso es que no puedo activar la opción, cuando la activo en el PCA, le doy a enviar, al volver a la página, sigue desactivada la opción.
Por ello pensé que me faltaría alguna extension o similar.
Como comento, le doy a habilitar, pulso enviar, retorno a la página y sigue deshabilitado, regresando a dicha página con pulsar regresar o directamente desde el menú de la izquierda.

Gracias y un saludo!
Avatar de Usuario
Por andares
#237519
Lo acabo de ver en el foro oficial, es debido a un error en la 3.2 que vendrá corregido en la próxima versión 3.2.1

Si no quieres esperar, se puede parchear con este archivo:
fix_cookie_notice_320
(1.57 KiB) Descargado 17 veces
Recuerda antes de nada hacer una copia de seguridad de la base de datos.

Extraerlo en la raiz de tu foro y accede a él con "/fix_cookie_notice_320.php"
wonder, karbiko le gusta esto
Por wonder
#237520
@andares, efectivamente, ahora si.
Baje el archivo, lo ejecuté, y a la primera.

Muchas muchisimas gracias!
Por wonder
#237523
Una consultilla al respecto de esto, que no se si se podrá solventar o no :)
El tema de que al pulsar en "Saber más", linke a una web con contenido en inglés, sabemos si estamos en legislación así? Una "tonterieta" que me ha venido a la cabeza...
Avatar de Usuario
Por andares
#237528
Si que se puede cambiar...del por que no lo han hecho de un buen inicio quien sabe :x

En la carpeta "template" de tu estilo en el archivo "overall_footer.html"

Busca:
Código: Seleccionar todo
					"link": "{LA_COOKIE_CONSENT_INFO}"
Reemplaza por:
Código: Seleccionar todo
					"link": "{LA_COOKIE_CONSENT_INFO}",
					"href": "{LA_COOKIE_CONSENT_LINK}"
En la carpeta "language/es/" en el archivo: "common.php"

Busca:
Código: Seleccionar todo
	'COOKIE_CONSENT_OK'		=> '¡Lo entiendo!',
Añade en una nueva linea despues:
Código: Seleccionar todo
	'COOKIE_CONSENT_LINK'	=> 'http://politicadecookies.com/cookies.php',
Aquí he puesto esta pagina de ejemplo, puedes cambiarla por la que gustes.

Limpia la cache desde el PCA y la cache de tu navegador.
wonder, ThE KuKa le gusta esto
Por wonder
#237531
Hubiese estado bien de inicio si, pero bueno, veo que es de "fácil solución" :)

Hice los cambios, subi los archivos, no fui capaz de limpiar caché desde PCA, no lo encontré, cabe mencionar que a estas horas y tras el día de hoy...si lo tengo delante es fácil no lo vea...Accedi a host, carpeta cache, elimine las dos carpetas que había (los dos archivos de raiz cache no), la de navegador y perfecto, ahora si, aparece linkando a página española.
Dejo esa, la veo muy bien.

Gracias!!!
Alguna extensión de ésto?

Hola qué tal, tengo tiempo buscando una ext[…]

No me creo que nadie use AUTO GROUP.... y pueda d[…]

Gracias AbaddonOrmuz, Quieres decir que, tengo qu[…]

Orange BBEs 1.2.1

Estilo actualizado a 1.2.1 Este estilo no ser&a[…]