imagenHace unos días que el "Staff" de phpBB España "charla" sobre el tema de soporte a diferentes versiones, en Enero del 2017 se cerrará el soporte phpBB 3.0 en el sitio oficial en Ingles.

Tras el anuncio de Fin de Soporte phpBB 3.0.x os recomendamos una vez más, actualizar a phpBB 3.1.x o phpBB 3.2.x ambas versiones estables. ✔

Después del 1 de Junio del 2017 nosotros, NO daremos soporte para phpBB 3.0.x y solamente se dará soporte para conversiones de foro a versiones 3.1.x y/o 3.2.x han sido 7 meses aprox. para que todo el mundo haya podido actualizar su foro.

Gracias.

La Administración de phpBB España.
Foros donde podréis dejar vuestras dudas sobre phpBB 3.1.x
  • Avatar de Usuario
  • Avatar de Usuario
  • Avatar de Usuario
Avatar de Usuario
Por Amblark
#238008
Saludos amigos de phpbb-es, necesito ayuda respecto a un error:

Finalmente y luego de pensármelo mucho, decidí actualizar mi Foro a la última versión 3.1.10, el proceso fue sumamente sencillo y no se presentó ninguna complicación salvo que al entrar al PCA me saltó el siguiente mensaje:

Imagen

Realicé los pasos correspondientes para la actualización de la base de datos y luego saltó el siguiente mensaje:

Imagen

Eliminé dicha carpeta y cuando intenté acceder nuevamente al Foro saltó este otro mensaje:

Imagen

Afortunadamente, aún se puede acceder y navegar por todas las secciones del Foro dándole clic en índice general, pero realmente me gustaría resolver este pequeño inconveniente.

¿Qué puedo hacer? Por favor, cualquier ayuda será apreciada.
#238017
Hola

¿Que versión estabas usando antes de la actualización? Es decir, ¿estabas usando la 3.1.4 que aparece en la captura o tenías una anterior y el proceso se paró en esa versión?
#238031
Efectivamente, estaba usando la versión 3.1.4 tal como aparece en la captura de pantalla. No fue que el proceso de actualización se detuvo allí por sí mismo, es que yo no quise actualizar a nuevas versiones para evitar errores de mi parte.

EDIT:

Me llama la atención el /app.php que aparece al final del enlace principal, puesto que cuando se accede desde otros enlaces (perteneciente a otras secciones del foro) se navega sin mayores problemas.
#238032
Precisamente, es que esa redirección a app.php no es normal ¿Hiciste alguna edicion en el archivo htaccess? ¿Que extensiones tienes instaladas?
#238033
No hice ninguna modificación al .htaccess ni a ningún otro archivo, sólo subí la carpeta install y sustituí la carpeta vendor (de la cual tengo una copia en la nube por si acaso) e inicié el proceso de actualización.

No tengo ninguna extención instalada, sólo tenía instalado el estilo we_universal pero lo desinstalé antes de iniciar el proceso de actualización.
#238094
¿Puedes copiar y pegar aquí tu archivo .htaccess por favor?

De todos modos prueba este archivo .htaccess a ver si se corrige:
Código: Seleccionar todo
<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>

<IfModule dir_module>
DirectoryIndex index.html index.php
</IfModule>
Si aún así no se corrige, puede que sea cosa de tu hosting y de mod_security

Saludos.
#238207
¡Saludos The Kuka! El código de mi .htaccess es el siguiente:
Código: Seleccionar todo
<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
   <IfVersion < 2.4>
      <Files "config.php">
         Order Allow,Deny
         Deny from All
      </Files>
      <Files "common.php">
         Order Allow,Deny
         Deny from All
      </Files>
   </IfVersion>
   <IfVersion >= 2.4>
      <Files "config.php">
         Require all denied
      </Files>
      <Files "common.php">
         Require all denied
      </Files>
   </IfVersion>
</IfModule>
<IfModule !mod_version.c>
   <IfModule !mod_authz_core.c>
      <Files "config.php">
         Order Allow,Deny
         Deny from All
      </Files>
      <Files "common.php">
         Order Allow,Deny
         Deny from All
      </Files>
   </IfModule>
   <IfModule mod_authz_core.c>
      <Files "config.php">
         Require all denied
      </Files>
      <Files "common.php">
         Require all denied
      </Files>
   </IfModule>
</IfModule>
Cabe resaltar que añadí el que me dejaste y el problema persiste. Hablé con el proveedor del hosting y dice que todo anda "de maravilla", así que asumo que entonces es un proble de mod_security.
Resetear usuarios

Sinceramente no me parece logico lo que comentas, […]

Es normal, es el comportamiento de varios navegado[…]

Permisos de Usuario

Gracias Karbiko

Actualizar de 3.0.14 a 3.2.0

Tienes acceso por SSH? busca en cPanel o pregunta […]